summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/gnuplot-mode/gnuplot-mode-0.8.0.ebuild')
-rw-r--r--app-emacs/gnuplot-mode/gnuplot-mode-0.8.0.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/app-emacs/gnuplot-mode/gnuplot-mode-0.8.0.ebuild b/app-emacs/gnuplot-mode/gnuplot-mode-0.8.0.ebuild
index 184d2694c411..7f29b6b43591 100644
--- a/app-emacs/gnuplot-mode/gnuplot-mode-0.8.0.ebuild
+++ b/app-emacs/gnuplot-mode/gnuplot-mode-0.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,11 +19,20 @@ IUSE="doc"
BDEPEND="doc? ( virtual/latex-base )"
RDEPEND="sci-visualization/gnuplot[-emacs(-)]"
+PATCHES=( "${FILESDIR}"/${PN}-0.8.0-tests.patch )
+
SITEFILE="50${PN}-gentoo.el"
DOCS=(CHANGELOG.org README.org)
DOC_CONTENTS="Please see ${SITELISP}/${PN}/gnuplot.el for the complete
documentation."
+src_prepare() {
+ elisp_src_prepare
+
+ # Erase broken tests
+ echo "(provide 'gnuplot-test-context)" > gnuplot-test-context.el || die
+}
+
src_compile() {
elisp_src_compile
use doc && { pdflatex gpelcard || die; }