summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/google-c-style/google-c-style-20091009-r1.ebuild')
-rw-r--r--app-emacs/google-c-style/google-c-style-20091009-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/google-c-style/google-c-style-20091009-r1.ebuild b/app-emacs/google-c-style/google-c-style-20091009-r1.ebuild
new file mode 100644
index 000000000000..3ac3bc90ea32
--- /dev/null
+++ b/app-emacs/google-c-style/google-c-style-20091009-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Provides the google C/C++ coding style"
+HOMEPAGE="http://code.google.com/p/google-styleguide/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S="${WORKDIR}"
+SITEFILE="50${PN}-gentoo.el"
+
+pkg_postinst() {
+ elisp-site-regen
+
+ elog "Example usage (~/.emacs):"
+ elog " (add-hook 'c-mode-common-hook 'google-set-c-style)"
+ elog " (add-hook 'c-mode-common-hook 'google-make-newline-indent)"
+}