summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/graphql/graphql-0.1.2.ebuild')
-rw-r--r--app-emacs/graphql/graphql-0.1.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/graphql/graphql-0.1.2.ebuild b/app-emacs/graphql/graphql-0.1.2.ebuild
new file mode 100644
index 000000000000..bcf800e586f4
--- /dev/null
+++ b/app-emacs/graphql/graphql-0.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+[[ "${PV}" == 0.1.2 ]] && COMMIT=67237f284f2dfb94f3cfba672ff64a37e1cb860f
+
+inherit elisp
+
+DESCRIPTION="GraphQL utilities"
+HOMEPAGE="https://github.com/vermiculus/graphql.el/"
+SRC_URI="https://github.com/vermiculus/graphql.el/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}.el-${COMMIT}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
+
+# Tries to download emake tool on the fly
+RESTRICT="test"
+
+src_prepare() {
+ # Avoid examples which would require circular dependencies
+ rm -f ${PN}-examples.el || die
+
+ default
+}