summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/graphql')
-rw-r--r--app-emacs/graphql/Manifest2
-rw-r--r--app-emacs/graphql/files/50graphql-gentoo.el1
-rw-r--r--app-emacs/graphql/graphql-0.1.2.ebuild (renamed from app-emacs/graphql/graphql-0.1.1.ebuild)16
3 files changed, 10 insertions, 9 deletions
diff --git a/app-emacs/graphql/Manifest b/app-emacs/graphql/Manifest
index b6e9ea7184ad..c11dbcc14116 100644
--- a/app-emacs/graphql/Manifest
+++ b/app-emacs/graphql/Manifest
@@ -1 +1 @@
-DIST graphql-0.1.1.tar.gz 6021 BLAKE2B 62755fda880042e00942acc6dbf98219521c92d052eeb0c584e8bb83ae8fdcea46185270f5dff8c89762d11b409e31b42d4ae62ab6831b04437ac0de517f442e SHA512 53f4c8b70be07f38b3554c4488a98ccdb956a68585955c7afd9df52d9d39cfaf7cc0efcadae1f42099495b8729851d089cd03d4570ed2a91a3354dd19f12d5bb
+DIST graphql-0.1.2.tar.gz 6231 BLAKE2B 55b121b3040b55c8c690637ef5fb034c66e2837e1c22c3e1b37911cc7c26741adb15344f861195f8156c33e844a950e4e6fe97acc502321a561b9c7b249c7aeb SHA512 45b1b72f4fafd884633dab3b464079ed7c80e671b4d0a5f26dc57f058177e5f54ed453710d36e02062d80abeee5e0215aff395063f8e3124646ffb05bdeff8c5
diff --git a/app-emacs/graphql/files/50graphql-gentoo.el b/app-emacs/graphql/files/50graphql-gentoo.el
deleted file mode 100644
index 431f7e90ae73..000000000000
--- a/app-emacs/graphql/files/50graphql-gentoo.el
+++ /dev/null
@@ -1 +0,0 @@
-(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/graphql/graphql-0.1.1.ebuild b/app-emacs/graphql/graphql-0.1.2.ebuild
index f559dbc5cc9d..bcf800e586f4 100644
--- a/app-emacs/graphql/graphql-0.1.1.ebuild
+++ b/app-emacs/graphql/graphql-0.1.2.ebuild
@@ -1,15 +1,17 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-NEED_EMACS=25
+EAPI=8
+
+[[ "${PV}" == 0.1.2 ]] && COMMIT=67237f284f2dfb94f3cfba672ff64a37e1cb860f
inherit elisp
DESCRIPTION="GraphQL utilities"
-HOMEPAGE="https://github.com/vermiculus/graphql.el"
-SRC_URI="https://github.com/vermiculus/graphql.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}.el-${PV}"
+HOMEPAGE="https://github.com/vermiculus/graphql.el/"
+SRC_URI="https://github.com/vermiculus/graphql.el/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}.el-${COMMIT}
LICENSE="GPL-3+"
SLOT="0"
@@ -23,7 +25,7 @@ RESTRICT="test"
src_prepare() {
# Avoid examples which would require circular dependencies
- rm -f examples.el || die
+ rm -f ${PN}-examples.el || die
default
}