summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/gruvbox-theme/gruvbox-theme-9999.ebuild')
-rw-r--r--app-emacs/gruvbox-theme/gruvbox-theme-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/gruvbox-theme/gruvbox-theme-9999.ebuild b/app-emacs/gruvbox-theme/gruvbox-theme-9999.ebuild
new file mode 100644
index 000000000000..f0931620842d
--- /dev/null
+++ b/app-emacs/gruvbox-theme/gruvbox-theme-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Gruvbox is a retro groove color scheme, now in Emacs"
+HOMEPAGE="https://github.com/greduan/emacs-theme-gruvbox/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/greduan/emacs-theme-gruvbox.git"
+else
+ SRC_URI="https://github.com/greduan/emacs-theme-gruvbox/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/emacs-theme-gruvbox-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/autothemer-0.2
+"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"