summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/ht/ht-2.3.ebuild')
-rw-r--r--app-emacs/ht/ht-2.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/ht/ht-2.3.ebuild b/app-emacs/ht/ht-2.3.ebuild
new file mode 100644
index 000000000000..57af14755328
--- /dev/null
+++ b/app-emacs/ht/ht-2.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="The missing hash table library for Emacs"
+HOMEPAGE="https://github.com/Wilfred/ht.el"
+SRC_URI="https://github.com/Wilfred/ht.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ht.el-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-emacs/dash-2.12.0
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/f
+ app-emacs/ert-runner
+ )
+"
+
+DOCS="CHANGELOG.md README.md"
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner --reporter ert+duration --script || die
+}