summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/jq-mode')
-rw-r--r--app-emacs/jq-mode/Manifest1
-rw-r--r--app-emacs/jq-mode/files/50jq-mode-gentoo.el4
-rw-r--r--app-emacs/jq-mode/jq-mode-0.5.0_p20220610.ebuild23
-rw-r--r--app-emacs/jq-mode/metadata.xml13
4 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/jq-mode/Manifest b/app-emacs/jq-mode/Manifest
new file mode 100644
index 000000000000..da28cb7bfa5b
--- /dev/null
+++ b/app-emacs/jq-mode/Manifest
@@ -0,0 +1 @@
+DIST jq-mode-0.5.0_p20220610.tar.gz 18987 BLAKE2B 28ec0b7133de36d6422c60de8b0f7d75f71c1bcef959734f02914ac8dc2c822d1d616e6bc7007fd7ea86efd038b6411640cc4d558024b5000798afd1b49fd790 SHA512 10ad3fd0c02531171d95a6724a4e635b7e2b2b3e49f87ce0323ca7b67653c614ed5e3588216b1374d9e9c67cca5d64df91f44feef3532e5e1ada68050764a6a4
diff --git a/app-emacs/jq-mode/files/50jq-mode-gentoo.el b/app-emacs/jq-mode/files/50jq-mode-gentoo.el
new file mode 100644
index 000000000000..6b35014a151c
--- /dev/null
+++ b/app-emacs/jq-mode/files/50jq-mode-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'jq-mode "jq-mode"
+ "Major mode for editing jq files" t)
+(add-to-list 'auto-mode-alist '("\\.jq\\'" . jq-mode))
diff --git a/app-emacs/jq-mode/jq-mode-0.5.0_p20220610.ebuild b/app-emacs/jq-mode/jq-mode-0.5.0_p20220610.ebuild
new file mode 100644
index 000000000000..4f3ec1123b6e
--- /dev/null
+++ b/app-emacs/jq-mode/jq-mode-0.5.0_p20220610.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT=071c1c29bac30351ad338136f2b625e5601365cd
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing jq queries"
+HOMEPAGE="https://github.com/ljos/jq-mode/"
+SRC_URI="https://github.com/ljos/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${COMMIT}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+RESTRICT="test" # tests fail, also they only test the ob integration
+
+RDEPEND="app-misc/jq"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/jq-mode/metadata.xml b/app-emacs/jq-mode/metadata.xml
new file mode 100644
index 000000000000..b4de977dc115
--- /dev/null
+++ b/app-emacs/jq-mode/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/ljos/jq-mode/issues/</bugs-to>
+ <remote-id type="github">ljos/jq-mode</remote-id>
+ </upstream>
+</pkgmetadata>