summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/js2-mode/js2-mode-20231224.ebuild')
-rw-r--r--app-emacs/js2-mode/js2-mode-20231224.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/js2-mode/js2-mode-20231224.ebuild b/app-emacs/js2-mode/js2-mode-20231224.ebuild
new file mode 100644
index 000000000000..ce8782cda510
--- /dev/null
+++ b/app-emacs/js2-mode/js2-mode-20231224.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Improved JavaScript editing mode for GNU Emacs"
+HOMEPAGE="https://github.com/mooz/js2-mode/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/mooz/${PN}.git"
+else
+ SRC_URI="https://github.com/mooz/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( NEWS.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ emake test
+}