summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/key-chord/key-chord-0.7.ebuild')
-rw-r--r--app-emacs/key-chord/key-chord-0.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emacs/key-chord/key-chord-0.7.ebuild b/app-emacs/key-chord/key-chord-0.7.ebuild
new file mode 100644
index 000000000000..84b6dd16e03b
--- /dev/null
+++ b/app-emacs/key-chord/key-chord-0.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Map pairs of simultaneously pressed keys to commands"
+HOMEPAGE="https://github.com/emacsorphanage/key-chord/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/emacsorphanage/${PN}.git"
+else
+ SRC_URI="https://github.com/emacsorphanage/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"