summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/kind-icon/kind-icon-0.2.2.ebuild')
-rw-r--r--app-emacs/kind-icon/kind-icon-0.2.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/kind-icon/kind-icon-0.2.2.ebuild b/app-emacs/kind-icon/kind-icon-0.2.2.ebuild
new file mode 100644
index 000000000000..8b334cdaa71c
--- /dev/null
+++ b/app-emacs/kind-icon/kind-icon-0.2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="27.1"
+
+inherit elisp
+
+DESCRIPTION="Completion kind icons"
+HOMEPAGE="https://github.com/jdtsmith/kind-icon/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/jdtsmith/${PN}.git"
+else
+ SRC_URI="https://github.com/jdtsmith/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/svg-lib
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-make-autoload-file
+ elisp_src_compile
+}