summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/kind-icon')
-rw-r--r--app-emacs/kind-icon/Manifest1
-rw-r--r--app-emacs/kind-icon/files/50kind-icon-gentoo.el3
-rw-r--r--app-emacs/kind-icon/kind-icon-0.2.2.ebuild39
-rw-r--r--app-emacs/kind-icon/metadata.xml20
4 files changed, 63 insertions, 0 deletions
diff --git a/app-emacs/kind-icon/Manifest b/app-emacs/kind-icon/Manifest
new file mode 100644
index 000000000000..0acf6e00abfa
--- /dev/null
+++ b/app-emacs/kind-icon/Manifest
@@ -0,0 +1 @@
+DIST kind-icon-0.2.2.tar.gz 22111 BLAKE2B dcdf964ebce9cfd89abdd1d8ad73b5734a09dc8971e5043e7d7d523d1ebcf48d5d9a45ade500395059d26fabf776f5486bee68a1be815987998386b23951bf44 SHA512 98573c3a73946628dc06cad5b3ad8cb81ddccc6ceea070e3a40edebb5f60cca78d21a6be3f4e2eb51fc9352fa4d071f1d0fc6a202fd3e03481d6880f85f8a6ea
diff --git a/app-emacs/kind-icon/files/50kind-icon-gentoo.el b/app-emacs/kind-icon/files/50kind-icon-gentoo.el
new file mode 100644
index 000000000000..b9e72be87371
--- /dev/null
+++ b/app-emacs/kind-icon/files/50kind-icon-gentoo.el
@@ -0,0 +1,3 @@
+;;; app-emacs/kind-icon site configuration -*- lexical-binding: t; -*-
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/kind-icon-autoloads.el" nil t)
diff --git a/app-emacs/kind-icon/kind-icon-0.2.2.ebuild b/app-emacs/kind-icon/kind-icon-0.2.2.ebuild
new file mode 100644
index 000000000000..8b334cdaa71c
--- /dev/null
+++ b/app-emacs/kind-icon/kind-icon-0.2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="27.1"
+
+inherit elisp
+
+DESCRIPTION="Completion kind icons"
+HOMEPAGE="https://github.com/jdtsmith/kind-icon/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/jdtsmith/${PN}.git"
+else
+ SRC_URI="https://github.com/jdtsmith/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/svg-lib
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-make-autoload-file
+ elisp_src_compile
+}
diff --git a/app-emacs/kind-icon/metadata.xml b/app-emacs/kind-icon/metadata.xml
new file mode 100644
index 000000000000..fda2bb3e66ad
--- /dev/null
+++ b/app-emacs/kind-icon/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>arsen@gentoo.org</email>
+ <name>Arsen Arsenović</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">jdtsmith/kind-icon</remote-id>
+ </upstream>
+</pkgmetadata>