summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/lice-el/lice-el-0.3.ebuild')
-rw-r--r--app-emacs/lice-el/lice-el-0.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/lice-el/lice-el-0.3.ebuild b/app-emacs/lice-el/lice-el-0.3.ebuild
new file mode 100644
index 000000000000..6cbd1e127c7f
--- /dev/null
+++ b/app-emacs/lice-el/lice-el-0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="License and header template for GNU Emacs"
+HOMEPAGE="https://github.com/buzztaiki/lice-el/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/buzztaiki/${PN}.git"
+else
+ SRC_URI="https://github.com/buzztaiki/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/${PN}-0.3-siteetc.patch" )
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+
+ sed -i "s|@SITEETC@|${EPREFIX}${SITEETC}/${PN}|" lice.el || die
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}/${PN}"
+ doins -r template
+}