summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/lv')
-rw-r--r--app-emacs/lv/lv-0.15.0-r1.ebuild33
-rw-r--r--app-emacs/lv/lv-0.15.0.ebuild20
2 files changed, 33 insertions, 20 deletions
diff --git a/app-emacs/lv/lv-0.15.0-r1.ebuild b/app-emacs/lv/lv-0.15.0-r1.ebuild
new file mode 100644
index 000000000000..cec213f0d313
--- /dev/null
+++ b/app-emacs/lv/lv-0.15.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Other echo area"
+HOMEPAGE="https://github.com/abo-abo/hydra/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/abo-abo/hydra.git"
+else
+ SRC_URI="https://github.com/abo-abo/hydra/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/hydra-${PV}"
+ KEYWORDS="amd64 ~arm64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile lv.el
+}
+
+src_install() {
+ elisp-install lv lv.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}
diff --git a/app-emacs/lv/lv-0.15.0.ebuild b/app-emacs/lv/lv-0.15.0.ebuild
deleted file mode 100644
index 0d4d7398dfb2..000000000000
--- a/app-emacs/lv/lv-0.15.0.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit elisp
-
-IUSE=""
-
-DESCRIPTION="Other echo area"
-HOMEPAGE="https://github.com/abo-abo/hydra"
-SRC_URI="https://github.com/abo-abo/hydra/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64"
-DOCS="README.md"
-
-SITEFILE="50${PN}-gentoo.el"
-
-S="${WORKDIR}/hydra-${PV}"