summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/modus-themes/modus-themes-4.3.0.ebuild')
-rw-r--r--app-emacs/modus-themes/modus-themes-4.3.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/modus-themes/modus-themes-4.3.0.ebuild b/app-emacs/modus-themes/modus-themes-4.3.0.ebuild
new file mode 100644
index 000000000000..e3ecfc9b2f8f
--- /dev/null
+++ b/app-emacs/modus-themes/modus-themes-4.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Highly accessible themes for GNU Emacs"
+HOMEPAGE="https://github.com/protesilaos/modus-themes/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/protesilaos/${PN}.git"
+else
+ SRC_URI="https://github.com/protesilaos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG.org README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+}