summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/mpg123-el')
-rw-r--r--app-emacs/mpg123-el/Manifest2
-rw-r--r--app-emacs/mpg123-el/files/50mpg123-el-gentoo.el3
-rw-r--r--app-emacs/mpg123-el/metadata.xml5
-rw-r--r--app-emacs/mpg123-el/mpg123-el-1.58.ebuild38
-rw-r--r--app-emacs/mpg123-el/mpg123-el-1.59.ebuild38
5 files changed, 86 insertions, 0 deletions
diff --git a/app-emacs/mpg123-el/Manifest b/app-emacs/mpg123-el/Manifest
new file mode 100644
index 000000000000..828aaaee9315
--- /dev/null
+++ b/app-emacs/mpg123-el/Manifest
@@ -0,0 +1,2 @@
+DIST mpg123-el-1.58.tar.bz2 34097 SHA256 efdd491329ba56096ad971bd5c2e2ceeea296fe8e26340d2370ae63bcdc33606 SHA512 53a67eb219acbeefeb8360a9d43279d2bb3efa48fa5df3787f2b7fad4f6b49402f319925bac3fc17ee1cad0dcbe38494c8162d4eb5e08261b2e505b40a66a987 WHIRLPOOL 83c8d660fd18d3faefff106c62127c0487c47824f9b53f157c27b127cd1dd624dad445217b99e5e3183ab02bf13fef3abdd077451ec8ce934c188fc356522181
+DIST mpg123-el-1.59.tar.xz 34076 SHA256 6105c3d11099a96cc5cb77909ca8d9e5ea4d5cb78b6a7ca185eb350425e075b4 SHA512 48fae024529be7b88553fc43fb626253f3d3a10d6709378a565a0d407374569e5573e52c0b26abc4d6f2f51ad7f680d655a1ac15ff696f4534c39a9a3536bc0e WHIRLPOOL 6434aa2368976698437c0a7ec12c126861c7f0096f4263f59b555b59c8d20377b5279ce09ceb99bb4b333318541126bb990009234cbd611ffdc2b91e980903f0
diff --git a/app-emacs/mpg123-el/files/50mpg123-el-gentoo.el b/app-emacs/mpg123-el/files/50mpg123-el-gentoo.el
new file mode 100644
index 000000000000..b65e6b16969d
--- /dev/null
+++ b/app-emacs/mpg123-el/files/50mpg123-el-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'mpg123 "mpg123" "A Front-end to mpg123" t)
+(setq id3*put-prog "tagput")
diff --git a/app-emacs/mpg123-el/metadata.xml b/app-emacs/mpg123-el/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/mpg123-el/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>
diff --git a/app-emacs/mpg123-el/mpg123-el-1.58.ebuild b/app-emacs/mpg123-el/mpg123-el-1.58.ebuild
new file mode 100644
index 000000000000..164fa8207596
--- /dev/null
+++ b/app-emacs/mpg123-el/mpg123-el-1.58.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp toolchain-funcs
+
+DESCRIPTION="Emacs front-end to mpg123 audio player and OggVorbis audio player"
+HOMEPAGE="http://www.gentei.org/~yuuji/software/mpg123el/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="mpg123-el"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="vorbis"
+
+RDEPEND="media-sound/mpg123
+ media-sound/alsa-utils
+ vorbis? ( media-sound/vorbis-tools )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -i -e "s/\(mainloop:\)/\1 ;/" tagput.c || die
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o tagput tagput.c || die
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o id3put id3put.c || die
+ elisp-compile *.el || die
+}
+
+src_install() {
+ dobin tagput id3put
+ elisp-install ${PN} *.el *.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+}
diff --git a/app-emacs/mpg123-el/mpg123-el-1.59.ebuild b/app-emacs/mpg123-el/mpg123-el-1.59.ebuild
new file mode 100644
index 000000000000..0db0a14b6af0
--- /dev/null
+++ b/app-emacs/mpg123-el/mpg123-el-1.59.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp toolchain-funcs
+
+DESCRIPTION="Emacs front-end to mpg123 audio player and OggVorbis audio player"
+HOMEPAGE="http://www.gentei.org/~yuuji/software/mpg123el/"
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="mpg123-el"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="vorbis"
+
+RDEPEND="media-sound/mpg123
+ media-sound/alsa-utils
+ vorbis? ( media-sound/vorbis-tools )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -i -e "s/\(mainloop:\)/\1 ;/" tagput.c || die
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o tagput tagput.c || die
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o id3put id3put.c || die
+ elisp-compile *.el
+}
+
+src_install() {
+ dobin tagput id3put
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}