summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/nginx-mode/nginx-mode-1.1.9.ebuild')
-rw-r--r--app-emacs/nginx-mode/nginx-mode-1.1.9.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-emacs/nginx-mode/nginx-mode-1.1.9.ebuild b/app-emacs/nginx-mode/nginx-mode-1.1.9.ebuild
new file mode 100644
index 000000000000..e912f207e1e1
--- /dev/null
+++ b/app-emacs/nginx-mode/nginx-mode-1.1.9.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs editing mode for Nginx config files"
+HOMEPAGE="http://github.com/ajc/nginx-mode"
+SRC_URI="https://github.com/ajc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="amd64 ~x86"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}