summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/org-contrib/org-contrib-0.4.2.ebuild')
-rw-r--r--app-emacs/org-contrib/org-contrib-0.4.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-emacs/org-contrib/org-contrib-0.4.2.ebuild b/app-emacs/org-contrib/org-contrib-0.4.2.ebuild
new file mode 100644
index 000000000000..5c5af7aa3af6
--- /dev/null
+++ b/app-emacs/org-contrib/org-contrib-0.4.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Contributed packages to Org"
+HOMEPAGE="https://www.orgmode.org/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~bzg/${PN}"
+else
+ SRC_URI="https://git.sr.ht/~bzg/${PN}/archive/release_${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-release_${PV}/lisp"
+
+ KEYWORDS="~amd64 ~ppc ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/org-mode-9.5"
+
+DOCS=( ../README.org )
+SITEFILE="50${PN}-gentoo.el"