summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/paredit')
-rw-r--r--app-emacs/paredit/Manifest3
-rw-r--r--app-emacs/paredit/metadata.xml14
-rw-r--r--app-emacs/paredit/paredit-24.ebuild30
-rw-r--r--app-emacs/paredit/paredit-26.ebuild36
4 files changed, 46 insertions, 37 deletions
diff --git a/app-emacs/paredit/Manifest b/app-emacs/paredit/Manifest
index 504ade03cf7c..38410fe9380f 100644
--- a/app-emacs/paredit/Manifest
+++ b/app-emacs/paredit/Manifest
@@ -1,2 +1 @@
-DIST paredit-23.html.xz 1920 BLAKE2B 029c09848bb162c135c882ca17e6d5da9c3c17ba3937a809dcd03edb4b1841a0069a72dbd6676003cdf1a9de60a1f88eefa1de050210a37b52a005d28892ab14 SHA512 0ef584787b6094f1d0720aeb4d3a8c106605be62ffaa240d27a190ed9a6dd83d6d1ce68c2d184e84539a0e0658dcbed068335b69f4b1905ae9bf3d9968d5fb9b
-DIST paredit-24.el.xz 24332 BLAKE2B 5243810cfcc40ebfd62ce3f833afa214defe9b91affbeb142ddad308e1fcff3f54a0ed19029a5ebd31f374868abc34f160d2efac65a609e783483ba2c92194d2 SHA512 76d9d2694473aeaab573964d79418fba20bfecef7f3771682f769ef05fb9385f9ef6dda1a5c7edec5d0a6f919d2eca5e75d595bd8cd5220c5179bfcac5f20f94
+DIST paredit-26.tar.gz 63322 BLAKE2B 6259b17655d0c1ebaa30fad2e46639f1e84e5aaee18980131d9e2cad9711ab469efc75a3ed264213bf3fbe18cddc9c69c0bb3907a3acfcc896aa2070cf00f44a SHA512 1f0a712d6b99740e559208451a3292e52b110a5f40224fdd30e390c4eb63f3b01790d8cc0a3fb0f0681a7739ca26763df6afbb4c2e00b6560dccb29950f70a70
diff --git a/app-emacs/paredit/metadata.xml b/app-emacs/paredit/metadata.xml
index 986088003fe1..5e20d8694796 100644
--- a/app-emacs/paredit/metadata.xml
+++ b/app-emacs/paredit/metadata.xml
@@ -1,9 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
<pkgmetadata>
-<maintainer type="project">
- <email>gnu-emacs@gentoo.org</email>
- <name>Gentoo GNU Emacs project</name>
-</maintainer>
-<stabilize-allarches/>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches />
+ <upstream>
+ <remote-id type="github">emacsmirror/paredit</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-emacs/paredit/paredit-24.ebuild b/app-emacs/paredit/paredit-24.ebuild
deleted file mode 100644
index da8b0fce3b6d..000000000000
--- a/app-emacs/paredit/paredit-24.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit elisp
-
-DESCRIPTION="Minor mode for performing structured editing of S-expressions"
-HOMEPAGE="https://mumble.net/~campbell/emacs/
- https://www.emacswiki.org/emacs/ParEdit"
-# No documentation available for paredit-24, so take previous version
-SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.xz
- https://dev.gentoo.org/~ulm/distfiles/${PN}-23.html.xz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
-
-SITEFILE="50${PN}-gentoo.el"
-
-src_unpack() {
- elisp_src_unpack
- mv ${PN}-23.html ${PN}.html || die
-}
-
-src_install() {
- elisp_src_install
- docinto html
- dodoc *.html
-}
diff --git a/app-emacs/paredit/paredit-26.ebuild b/app-emacs/paredit/paredit-26.ebuild
new file mode 100644
index 000000000000..130788d7d6b8
--- /dev/null
+++ b/app-emacs/paredit/paredit-26.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Minor mode for performing structured editing of S-expressions"
+HOMEPAGE="https://paredit.org/
+ https://www.emacswiki.org/emacs/ParEdit/
+ https://github.com/emacsmirror/paredit/"
+SRC_URI="https://github.com/emacsmirror/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DOCS=( CREDITS NEWS ${PN}.html )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ sh ./genhtml.sh || die "the script genhtml.sh failed"
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -l ${PN}.el -l test.el || die "tests failed"
+}
+
+src_install() {
+ rm test.el* || die
+
+ elisp_src_install
+}