summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/parseedn/parseedn-1.2.1.ebuild')
-rw-r--r--app-emacs/parseedn/parseedn-1.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/parseedn/parseedn-1.2.1.ebuild b/app-emacs/parseedn/parseedn-1.2.1.ebuild
new file mode 100644
index 000000000000..4d4b7b12cefa
--- /dev/null
+++ b/app-emacs/parseedn/parseedn-1.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp
+
+DESCRIPTION="EDN parser for Emacs Lisp"
+HOMEPAGE="https://github.com/clojure-emacs/parseedn/"
+SRC_URI="https://github.com/clojure-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-emacs/parseclj"
+BDEPEND="
+ ${RDEPEND}
+ test? ( app-emacs/ert-runner )
+"
+
+ELISP_REMOVE="test/${PN}-test.el" # Remove bad tests.
+DOCS=( CHANGELOG.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}