summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/plz/plz-0.7.2.ebuild')
-rw-r--r--app-emacs/plz/plz-0.7.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-emacs/plz/plz-0.7.2.ebuild b/app-emacs/plz/plz-0.7.2.ebuild
new file mode 100644
index 000000000000..7397ae367c6f
--- /dev/null
+++ b/app-emacs/plz/plz-0.7.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="HTTP library with curl backend for GNU Emacs"
+HOMEPAGE="https://github.com/alphapapa/plz.el/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alphapapa/plz.el.git"
+else
+ SRC_URI="https://github.com/alphapapa/plz.el/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/plz.el-${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+PROPERTIES="test_network" # Tests require network access.
+RESTRICT="test"
+
+RDEPEND="net-misc/curl"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert tests -l tests/test-plz.el
+
+src_install() {
+ elisp_src_install
+
+ doinfo ${PN}.info
+}