summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/plz')
-rw-r--r--app-emacs/plz/Manifest1
-rw-r--r--app-emacs/plz/metadata.xml20
-rw-r--r--app-emacs/plz/plz-0.7.2.ebuild37
3 files changed, 58 insertions, 0 deletions
diff --git a/app-emacs/plz/Manifest b/app-emacs/plz/Manifest
new file mode 100644
index 000000000000..3ebbf19d58ec
--- /dev/null
+++ b/app-emacs/plz/Manifest
@@ -0,0 +1 @@
+DIST plz-0.7.2.tar.gz 105864 BLAKE2B b876f69a61452ca932c70e87d35e4442f1ddae4c74c3e124056ff0adae9923d0a374c047a1c1dade705713a9b2aaa5bbfbb73368fde9564b53ce638f90f08ff0 SHA512 01951bbb0e59d6196338a806b4bab030538c411d185acf5462bc1eb4d3130b1da5d78a436e84163dd8167b3705edb6dcafdeef8d4611973521566d34f2ca5654
diff --git a/app-emacs/plz/metadata.xml b/app-emacs/plz/metadata.xml
new file mode 100644
index 000000000000..312ec018bd3c
--- /dev/null
+++ b/app-emacs/plz/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ plz is an HTTP library for Emacs. It uses curl as a backend, which avoids
+ some of the issues with using Emacs's built-in url library. It supports
+ both synchronous and asynchronous requests. Its API is intended to be
+ simple, natural, and expressive. Its code is intended to be simple and
+ well-organized. Every feature is tested against httpbin.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/alphapapa/plz.el/issues/</bugs-to>
+ <remote-id type="github">alphapapa/plz.el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/plz/plz-0.7.2.ebuild b/app-emacs/plz/plz-0.7.2.ebuild
new file mode 100644
index 000000000000..7397ae367c6f
--- /dev/null
+++ b/app-emacs/plz/plz-0.7.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="HTTP library with curl backend for GNU Emacs"
+HOMEPAGE="https://github.com/alphapapa/plz.el/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alphapapa/plz.el.git"
+else
+ SRC_URI="https://github.com/alphapapa/plz.el/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/plz.el-${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+PROPERTIES="test_network" # Tests require network access.
+RESTRICT="test"
+
+RDEPEND="net-misc/curl"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert tests -l tests/test-plz.el
+
+src_install() {
+ elisp_src_install
+
+ doinfo ${PN}.info
+}