summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/polymode/polymode-0.2.2_p20220322.ebuild')
-rw-r--r--app-emacs/polymode/polymode-0.2.2_p20220322.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/polymode/polymode-0.2.2_p20220322.ebuild b/app-emacs/polymode/polymode-0.2.2_p20220322.ebuild
new file mode 100644
index 000000000000..4b29818b0b7d
--- /dev/null
+++ b/app-emacs/polymode/polymode-0.2.2_p20220322.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT=2094c92403fe395dfb2b8b2521da1012a966e9ab
+
+inherit elisp
+
+DESCRIPTION="Framework for Multiple Major Modes in Emacs"
+HOMEPAGE="https://github.com/polymode/polymode/"
+SRC_URI="https://github.com/polymode/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${COMMIT}
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+DOCS=( readme.md )
+# The "compat-tests" downloads resources from network and "define-tests" fails
+ELISP_REMOVE="tests/compat-tests.el tests/define-tests.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . --load targets/test.el
+}
+
+src_install() {
+ elisp_src_install
+
+ dodoc -r samples
+}