summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/powerline/powerline-2.5_p20221110.ebuild')
-rw-r--r--app-emacs/powerline/powerline-2.5_p20221110.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emacs/powerline/powerline-2.5_p20221110.ebuild b/app-emacs/powerline/powerline-2.5_p20221110.ebuild
new file mode 100644
index 000000000000..ad42fcd4eb8b
--- /dev/null
+++ b/app-emacs/powerline/powerline-2.5_p20221110.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+[[ ${PV} = *_p20221110 ]] && COMMIT=c35c35bdf5ce2d992882c1f06f0f078058870d4a
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs version of the Vim powerline"
+HOMEPAGE="https://github.com/milkypostman/powerline/"
+SRC_URI="https://github.com/milkypostman/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${COMMIT}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}