summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/powershell/powershell-0.3_pre20220805.ebuild')
-rw-r--r--app-emacs/powershell/powershell-0.3_pre20220805.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/powershell/powershell-0.3_pre20220805.ebuild b/app-emacs/powershell/powershell-0.3_pre20220805.ebuild
new file mode 100644
index 000000000000..ef23378c37c5
--- /dev/null
+++ b/app-emacs/powershell/powershell-0.3_pre20220805.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs mode for editing and running PowerShell code"
+HOMEPAGE="https://github.com/jschaf/powershell.el/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jschaf/${PN}.el.git"
+else
+ if [[ ${PV} == *_pre20220805 ]] ; then
+ COMMIT=f2da15857e430206e215a3c65289b4058ae3c976
+ SRC_URI="https://github.com/jschaf/${PN}.el/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}.el-${COMMIT}
+ else
+ SRC_URI="https://github.com/jschaf/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}.el-${PV}
+ fi
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"