summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/powershell')
-rw-r--r--app-emacs/powershell/Manifest2
-rw-r--r--app-emacs/powershell/files/50powershell-gentoo.el6
-rw-r--r--app-emacs/powershell/metadata.xml14
-rw-r--r--app-emacs/powershell/powershell-0.3_pre20220402.ebuild20
-rw-r--r--app-emacs/powershell/powershell-0.3_pre20220805.ebuild32
5 files changed, 74 insertions, 0 deletions
diff --git a/app-emacs/powershell/Manifest b/app-emacs/powershell/Manifest
new file mode 100644
index 000000000000..20d10605dcd7
--- /dev/null
+++ b/app-emacs/powershell/Manifest
@@ -0,0 +1,2 @@
+DIST powershell-0.3_pre20220402.tar.gz 17009 BLAKE2B c369993bc4ac0e681dde514c4303f6c131198e77f6aa3b293ecedefa552e8f2b94e8ab77978ff2f8d999a4b620fa4e013023a283e0a2c30f6578428bc54fe52d SHA512 2d38f1a968119a2022e1f3eceb8150947559e5e7943d184fec3b8075cc2dc8d97b5a897bc1ac97b14d69d9424b72ca20f01d24589403936b1ca2bc7becc2ea0f
+DIST powershell-0.3_pre20220805.tar.gz 17010 BLAKE2B 7bc942ecdba9141c666f34116ef619176fa08309e35ad7f51a6a1003633851001e2dcab3c115af2fd14fa781f8818c2b0e4ea3591ff30cb644cb1cad5ddf0473 SHA512 5e511d9b2106888509b388a4ada26f4b581c5fb32334ddb6ef50dfd57ab20d28ee84ac999a373ade9be85b5444fb2903cfea0cf229775fd78839b0372ecf9ac6
diff --git a/app-emacs/powershell/files/50powershell-gentoo.el b/app-emacs/powershell/files/50powershell-gentoo.el
new file mode 100644
index 000000000000..e97cc3554edc
--- /dev/null
+++ b/app-emacs/powershell/files/50powershell-gentoo.el
@@ -0,0 +1,6 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'powershell "powershell"
+ "Run an inferior PowerShell." t)
+(autoload 'powershell-mode "powershell"
+ "Major mode for editing PowerShell scripts." t)
+(add-to-list 'auto-mode-alist '("\\.ps[dm]?1\\'" . powershell-mode))
diff --git a/app-emacs/powershell/metadata.xml b/app-emacs/powershell/metadata.xml
new file mode 100644
index 000000000000..ed7371a06f5f
--- /dev/null
+++ b/app-emacs/powershell/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <bugs-to>https://github.com/jschaf/powershell.el/issues/</bugs-to>
+ <remote-id type="github">jschaf/powershell.el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/powershell/powershell-0.3_pre20220402.ebuild b/app-emacs/powershell/powershell-0.3_pre20220402.ebuild
new file mode 100644
index 000000000000..e655c5108c75
--- /dev/null
+++ b/app-emacs/powershell/powershell-0.3_pre20220402.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT=77b27faf8a292f1dc9f54c872241dc53b6791bf1
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs mode for editing and running PowerShell code"
+HOMEPAGE="https://github.com/jschaf/powershell.el/"
+SRC_URI="https://github.com/jschaf/${PN}.el/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}.el-${COMMIT}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/powershell/powershell-0.3_pre20220805.ebuild b/app-emacs/powershell/powershell-0.3_pre20220805.ebuild
new file mode 100644
index 000000000000..ef23378c37c5
--- /dev/null
+++ b/app-emacs/powershell/powershell-0.3_pre20220805.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs mode for editing and running PowerShell code"
+HOMEPAGE="https://github.com/jschaf/powershell.el/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jschaf/${PN}.el.git"
+else
+ if [[ ${PV} == *_pre20220805 ]] ; then
+ COMMIT=f2da15857e430206e215a3c65289b4058ae3c976
+ SRC_URI="https://github.com/jschaf/${PN}.el/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}.el-${COMMIT}
+ else
+ SRC_URI="https://github.com/jschaf/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}.el-${PV}
+ fi
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"