summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/pymacs')
-rw-r--r--app-emacs/pymacs/Manifest2
-rw-r--r--app-emacs/pymacs/files/50pymacs-gentoo.el5
-rw-r--r--app-emacs/pymacs/metadata.xml9
-rw-r--r--app-emacs/pymacs/pymacs-0.23-r1.ebuild53
-rw-r--r--app-emacs/pymacs/pymacs-0.25-r1.ebuild45
5 files changed, 114 insertions, 0 deletions
diff --git a/app-emacs/pymacs/Manifest b/app-emacs/pymacs/Manifest
new file mode 100644
index 000000000000..0ad92dcc70cd
--- /dev/null
+++ b/app-emacs/pymacs/Manifest
@@ -0,0 +1,2 @@
+DIST Pymacs-0.23.tar.gz 92161 SHA256 eb419e307c9670ac5ad76de44c8803bd91ff0a1a8d6b6035fa4d0427a85f5163 SHA512 c07cc4fa75ca3f03a517563172c9647f1f8402bfe7cdac45aa285c838fe15ab4fd08cb2a0364d985fc4d0ad5670436c4f2c6fa81efe1424b10d2a430699308d3 WHIRLPOOL 5477b4eaf9c134f80101be9a83c2285d8105aeaa189e4f39190abb024073e942c660fe74eff2defb42f5422d64fe73cb24b8e206c53f624aec0e1a9795db4f58
+DIST pymacs-0.25.tar.gz 120597 SHA256 51dc21b33316e6e244e78e5e88d8ae9a88afc0dcef34ba702ea9be589839bec2 SHA512 e17f7ee754413e21403d23894ee263fb0edae180a60c746b02cf101b2f0c782116e7bb61215bd0a8c689a991e211d780d220d4672b58f43108e7218a6f0c8dc0 WHIRLPOOL 90a211d1b62387e05deb759786fd82eeed23c1800307f1345e1c06c579c0455480433c24fda34a881f887595e169076a6ed56f6e8774933f0431aa96940e0152
diff --git a/app-emacs/pymacs/files/50pymacs-gentoo.el b/app-emacs/pymacs/files/50pymacs-gentoo.el
new file mode 100644
index 000000000000..8c59be7e3365
--- /dev/null
+++ b/app-emacs/pymacs/files/50pymacs-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'pymacs-load "pymacs" nil t)
+(autoload 'pymacs-eval "pymacs" nil t)
+(autoload 'pymacs-apply "pymacs")
+(autoload 'pymacs-call "pymacs")
diff --git a/app-emacs/pymacs/metadata.xml b/app-emacs/pymacs/metadata.xml
new file mode 100644
index 000000000000..3f864cf6504f
--- /dev/null
+++ b/app-emacs/pymacs/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<herd>python</herd>
+<upstream>
+ <remote-id type="github">pinard/Pymacs</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/pymacs/pymacs-0.23-r1.ebuild b/app-emacs/pymacs/pymacs-0.23-r1.ebuild
new file mode 100644
index 000000000000..3172e9a607d5
--- /dev/null
+++ b/app-emacs/pymacs/pymacs-0.23-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit distutils elisp
+
+MY_P=Pymacs-${PV}
+DESCRIPTION="A tool that allows both-side communication beetween Python and Emacs Lisp"
+HOMEPAGE="http://pymacs.progiciels-bpi.ca/"
+SRC_URI="http://pymacs.progiciels-bpi.ca/archives/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ia64 ppc ppc64 s390 sh x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+# additional doc? dependencies for multirow.sty and aeguill.sty (bug 247703)
+DEPEND="
+ doc? ( dev-python/docutils
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-langfrench )"
+RDEPEND=""
+
+SITEFILE=50${PN}-gentoo.el
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_compile() {
+ emake || die "emake failed"
+ elisp-compile pymacs.el || die "elisp-compile failed"
+ if use doc; then
+ VARTEXFONTS="${T}"/fonts \
+ emake pymacs.pdf || die "emake pymacs.pdf failed"
+ fi
+}
+
+src_install() {
+ elisp_src_install
+ distutils_src_install
+ dodoc THANKS pymacs.rst
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins pymacs.pdf
+ fi
+}
diff --git a/app-emacs/pymacs/pymacs-0.25-r1.ebuild b/app-emacs/pymacs/pymacs-0.25-r1.ebuild
new file mode 100644
index 000000000000..4f1f9b6eec2c
--- /dev/null
+++ b/app-emacs/pymacs/pymacs-0.25-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit elisp distutils-r1 vcs-snapshot
+
+DESCRIPTION="A tool that allows both-side communication beetween Python and Emacs Lisp"
+HOMEPAGE="http://www.emacswiki.org/emacs/PyMacs"
+SRC_URI="https://github.com/pinard/Pymacs/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="doc? ( >=dev-python/docutils-0.7
+ virtual/latex-base )"
+RDEPEND=""
+
+DISTUTILS_IN_SOURCE_BUILD=1
+SITEFILE="50${PN}-gentoo.el"
+
+# called by distutils-r1 for every python implementation
+python_configure() {
+ # pre-process the files but don't run distutils
+ emake PYSETUP=: PYTHON=${EPYTHON}
+}
+
+# called once
+python_compile_all() {
+ elisp_src_compile
+ if use doc; then
+ VARTEXFONTS="${T}"/fonts emake RST2LATEX=rst2latex.py pymacs.pdf
+ fi
+}
+
+python_install_all() {
+ elisp_src_install
+ distutils-r1_python_install_all
+ dodoc pymacs.rst
+ use doc && dodoc pymacs.pdf
+}