summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/reformatter')
-rw-r--r--app-emacs/reformatter/Manifest2
-rw-r--r--app-emacs/reformatter/metadata.xml13
-rw-r--r--app-emacs/reformatter/reformatter-0.6.ebuild21
-rw-r--r--app-emacs/reformatter/reformatter-0.7.ebuild21
4 files changed, 57 insertions, 0 deletions
diff --git a/app-emacs/reformatter/Manifest b/app-emacs/reformatter/Manifest
new file mode 100644
index 000000000000..f3a169ee3b6d
--- /dev/null
+++ b/app-emacs/reformatter/Manifest
@@ -0,0 +1,2 @@
+DIST reformatter-0.6.tar.gz 7943 BLAKE2B 72f34b873aacef5ee1dd0edd06effed83dad490f5d57ac3390dbd0d6fb7172adb1b7a3e19c0e90740b300cad8d2a1df60ab1bbfaa660c79621066d402f01b923 SHA512 ff1ad88b3a0a3ca1e70a5e0d7fe6f2264981d88ae64f0fa412d52721fb43991a483f31fb72193f7d67be71f39110051c0dda39e4ed87b4339aa156fa256e013a
+DIST reformatter-0.7.tar.gz 8294 BLAKE2B 52e516d9c56798d924c30b0ff68e0441229aa7644fa3944fabaacd2452da03810deacd3e363504c99de6777149da72606397a6d28822d34335250cd341d69082 SHA512 2b45dfc1440dbbb4f8ec0ab6a2e69b2686ad6983a074bb9bf1863347186ced197e2f5b23baf2fccd382e113d1813211a0173c246af1ef47447722b3c33fb4207
diff --git a/app-emacs/reformatter/metadata.xml b/app-emacs/reformatter/metadata.xml
new file mode 100644
index 000000000000..7cdcedd7a960
--- /dev/null
+++ b/app-emacs/reformatter/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/purcell/emacs-reformatter/issues/</bugs-to>
+ <remote-id type="github">purcell/emacs-reformatter</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/reformatter/reformatter-0.6.ebuild b/app-emacs/reformatter/reformatter-0.6.ebuild
new file mode 100644
index 000000000000..f932f87ee31f
--- /dev/null
+++ b/app-emacs/reformatter/reformatter-0.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Define commands which run reformatters on the Emacs buffers"
+HOMEPAGE="https://github.com/purcell/emacs-reformatter/"
+SRC_URI="https://github.com/purcell/emacs-${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/emacs-${P}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Tests need "shfmt"
+
+DOCS=( README.md )
+ELISP_REMOVE="Makefile ${PN}-tests.el" # Makefile downloads pkgs from net
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/reformatter/reformatter-0.7.ebuild b/app-emacs/reformatter/reformatter-0.7.ebuild
new file mode 100644
index 000000000000..8b7a89a41ef4
--- /dev/null
+++ b/app-emacs/reformatter/reformatter-0.7.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Define commands which run reformatters on the Emacs buffers"
+HOMEPAGE="https://github.com/purcell/emacs-reformatter/"
+SRC_URI="https://github.com/purcell/emacs-${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/emacs-${P}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+RESTRICT="test" # Tests need "shfmt"
+
+DOCS=( README.md )
+ELISP_REMOVE="Makefile ${PN}-tests.el" # Makefile downloads pkgs from net
+SITEFILE="50${PN}-gentoo.el"