summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/rust-mode/rust-mode-1.0.5.ebuild')
-rw-r--r--app-emacs/rust-mode/rust-mode-1.0.5.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/app-emacs/rust-mode/rust-mode-1.0.5.ebuild b/app-emacs/rust-mode/rust-mode-1.0.5.ebuild
index bd23bef33b88..ad4ba5f74a17 100644
--- a/app-emacs/rust-mode/rust-mode-1.0.5.ebuild
+++ b/app-emacs/rust-mode/rust-mode-1.0.5.ebuild
@@ -1,25 +1,28 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-NEED_EMACS=24
-
inherit elisp
DESCRIPTION="A major emacs mode for editing Rust source code"
HOMEPAGE="https://github.com/rust-lang/rust-mode"
-SRC_URI="https://github.com/rust-lang/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rust-lang/${PN}.git"
+else
+ SRC_URI="https://github.com/rust-lang/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
LICENSE="|| ( MIT Apache-2.0 )"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/${P}-tests.patch )
DOCS=( README.md )
SITEFILE="50${PN}-gentoo.el"
-src_test() {
- ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
- -l rust-mode.el -l rust-mode-tests.el \
- -f ert-run-tests-batch-and-exit || die "tests failed"
-}
+elisp-enable-tests ert "${S}" -l ${PN}-tests.el