summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/scala-ts-mode/scala-ts-mode-1.0.0_p20240316.ebuild')
-rw-r--r--app-emacs/scala-ts-mode/scala-ts-mode-1.0.0_p20240316.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/scala-ts-mode/scala-ts-mode-1.0.0_p20240316.ebuild b/app-emacs/scala-ts-mode/scala-ts-mode-1.0.0_p20240316.ebuild
new file mode 100644
index 000000000000..f7cfef4ef361
--- /dev/null
+++ b/app-emacs/scala-ts-mode/scala-ts-mode-1.0.0_p20240316.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+MY_COMMIT="11a01d726ac4fafb8a6688459ac79b41333bd6c8"
+DESCRIPTION="Emacs Scala Mode via Tree-Sitter"
+HOMEPAGE="https://github.com/KaranAhlawat/scala-ts-mode"
+SRC_URI="
+ https://codeload.github.com/KaranAhlawat/scala-ts-mode/tar.gz/${MY_COMMIT}
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64"
+
+RDEPEND="
+ >=app-editors/emacs-29[tree-sitter]
+ dev-libs/tree-sitter-scala
+"
+
+DOCS="README.org"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}