summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/swift-mode/swift-mode-9.1.0.ebuild')
-rw-r--r--app-emacs/swift-mode/swift-mode-9.1.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/swift-mode/swift-mode-9.1.0.ebuild b/app-emacs/swift-mode/swift-mode-9.1.0.ebuild
new file mode 100644
index 000000000000..c996fb0680cb
--- /dev/null
+++ b/app-emacs/swift-mode/swift-mode-9.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs support for Apple's Swift programming language"
+HOMEPAGE="https://github.com/swift-emacs/swift-mode/"
+SRC_URI="https://github.com/swift-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DOCS=( README.md CONTRIBUTING.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} \
+ -L . -L test \
+ -l test/swift-mode-test.el \
+ -f swift-mode:run-test || die "tests failed"
+}