summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/tablist')
-rw-r--r--app-emacs/tablist/Manifest1
-rw-r--r--app-emacs/tablist/metadata.xml20
-rw-r--r--app-emacs/tablist/tablist-1.1.ebuild26
3 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/tablist/Manifest b/app-emacs/tablist/Manifest
new file mode 100644
index 000000000000..d656f7ee9615
--- /dev/null
+++ b/app-emacs/tablist/Manifest
@@ -0,0 +1 @@
+DIST tablist-1.1.tar.gz 32064 BLAKE2B 0aceea5784d2b2c0778821a59e9bf4fb6b1d619a85f30603d5878fbb43b763d9b20a8962c3aafaafd50f41f824bcb9612de68010fefe4f8e2a84b5fdca31645c SHA512 8f74c7fcd682024011aade568a1bb0f2e5e0813eeefc94efc24d4cdf0aac34818c545f8f85adb5bd85bc62dc41c30979be908dc9a6d22537abc35daf036bdf72
diff --git a/app-emacs/tablist/metadata.xml b/app-emacs/tablist/metadata.xml
new file mode 100644
index 000000000000..06ca23f7f9c4
--- /dev/null
+++ b/app-emacs/tablist/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This package adds marks and filters to tabulated-list-mode. It also puts a
+ dired face on tabulated list buffers. It can be used by deriving from
+ tablist-mode, or with more limited features by enabling tablist-minor-mode
+ inside a tabulated-list-mode buffer.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/politza/tablist/issues/</bugs-to>
+ <remote-id type="github">politza/tablist</remote-id>
+ </upstream>
+ <stabilize-allarches />
+</pkgmetadata>
diff --git a/app-emacs/tablist/tablist-1.1.ebuild b/app-emacs/tablist/tablist-1.1.ebuild
new file mode 100644
index 000000000000..9dca1d070b4f
--- /dev/null
+++ b/app-emacs/tablist/tablist-1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Extended tabulated-list mode fro Emacs"
+HOMEPAGE="https://github.com/emacsorphanage/tablist/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/emacsorphanage/${PN}.git"
+else
+ SRC_URI="https://github.com/emacsorphanage/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"