summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/treemacs')
-rw-r--r--app-emacs/treemacs/Manifest4
-rw-r--r--app-emacs/treemacs/files/treemacs-2.9.5-tests.patch11
-rw-r--r--app-emacs/treemacs/files/treemacs-async-scripts.patch29
-rw-r--r--app-emacs/treemacs/treemacs-2.10-r1.ebuild61
-rw-r--r--app-emacs/treemacs/treemacs-2.9.5-r1.ebuild61
-rw-r--r--app-emacs/treemacs/treemacs-3.1-r1.ebuild80
-rw-r--r--app-emacs/treemacs/treemacs-3.1_p20240229.ebuild83
7 files changed, 205 insertions, 124 deletions
diff --git a/app-emacs/treemacs/Manifest b/app-emacs/treemacs/Manifest
index e3daff3ffdcf..67c445fbf04e 100644
--- a/app-emacs/treemacs/Manifest
+++ b/app-emacs/treemacs/Manifest
@@ -1,2 +1,2 @@
-DIST treemacs-2.10.tar.gz 4137468 BLAKE2B 0f832d02f8b0f96f7000c57b1842319155face5cb50c44ff4286f7f28dd74b38739079de9c387dbddbf93af37a5c750c45a598100ed5053674a565b4ec34f0c6 SHA512 9326a3f66c1b38eb7ef39e90900c2ef71d20c6c3478213f61c144ca4face562dccf00d6d400315c264627468a0c3319a24f0ec6cddb795b54e1b7f3c235d1c71
-DIST treemacs-2.9.5.tar.gz 4134227 BLAKE2B 1fbdb278e9524fdb14cbc7699bc787ab694b00d37a91ec3e91e106079bc02f6b8b39207608873d45c70fd6355a22553bf1a0636a948b79df77adfe0b4a3f799f SHA512 adc026d7ad459418fae531c5a1a7df7f9308e63dec82240c1c5e278eb00fdf8d6dff1ee2112ea73d5a05c4266efe24623bb84f8819a6f07fbb4fde6e644ca9ad
+DIST treemacs-3.1.tar.gz 4562915 BLAKE2B b728c6ea795fe1159c2342b593cc4e6b3d06a1ba58dca876e5472e394b77a3a9930740aa9ecb65973f551322018920f08b0b49e897d5677b7a0f1da42cfad2d3 SHA512 e891cfa68916ecc250ab0446a4eb0149deea17a7f366870ce757e73f175bc823dae87080a584ea315d502c50559d030055f2f399cbd92d40af8c2dca5308604c
+DIST treemacs-3.1_p20240229.tar.gz 4701534 BLAKE2B 3b3e5dbef181efee4739f96ee0ef0de68f344fa68b890b22c0ec808ec1c3b7afc6cd353124e2c6e5e70c931492ac0c9a3e4cee5c66b5c25ba4cc72b296ade6f0 SHA512 40631b77a71b13b0aed2f703386d98b8444c7630f952ba8d49160ba99abc13b8636169fee8cd23bbc372a7d7ae83b863e11ac891deb8cc5d2e961ccfee9f60da
diff --git a/app-emacs/treemacs/files/treemacs-2.9.5-tests.patch b/app-emacs/treemacs/files/treemacs-2.9.5-tests.patch
new file mode 100644
index 000000000000..afa46664802d
--- /dev/null
+++ b/app-emacs/treemacs/files/treemacs-2.9.5-tests.patch
@@ -0,0 +1,11 @@
+--- a/test/treemacs-test.el
++++ b/test/treemacs-test.el
+@@ -1079,7 +1079,7 @@
+
+ (describe "treemacs--parse-collapsed-dirs"
+
+- (it "Finds dirs to flatten in test directory"
++ (xit "Finds dirs to flatten in test directory"
+ (-let [treemacs-collapse-dirs 3]
+ (expect (-> treemacs-dir
+ (treemacs-join-path "test")
diff --git a/app-emacs/treemacs/files/treemacs-async-scripts.patch b/app-emacs/treemacs/files/treemacs-async-scripts.patch
new file mode 100644
index 000000000000..0a3ef104c733
--- /dev/null
+++ b/app-emacs/treemacs/files/treemacs-async-scripts.patch
@@ -0,0 +1,29 @@
+--- a/src/elisp/treemacs-async.el
++++ b/src/elisp/treemacs-async.el
+@@ -43,22 +43,22 @@
+ (defconst treemacs--dirs-to-collapse.py
+ (if (member "treemacs-dirs-to-collapse.py" (directory-files treemacs-dir))
+ (treemacs-join-path treemacs-dir "treemacs-dirs-to-collapse.py")
+- (treemacs-join-path treemacs-dir "src/scripts/treemacs-dirs-to-collapse.py")))
++ (treemacs-join-path treemacs-dir "@SITEETC@/scripts/treemacs-dirs-to-collapse.py")))
+
+ (defconst treemacs--git-status.py
+ (if (member "treemacs-git-status.py" (directory-files treemacs-dir))
+ (treemacs-join-path treemacs-dir "treemacs-git-status.py")
+- (treemacs-join-path treemacs-dir "src/scripts/treemacs-git-status.py")))
++ (treemacs-join-path treemacs-dir "@SITEETC@/scripts/treemacs-git-status.py")))
+
+ (defconst treemacs--single-file-git-status.py
+ (if (member "treemacs-single-file-git-status.py" (directory-files treemacs-dir))
+ (treemacs-join-path treemacs-dir "treemacs-single-file-git-status.py")
+- (treemacs-join-path treemacs-dir "src/scripts/treemacs-single-file-git-status.py")))
++ (treemacs-join-path treemacs-dir "@SITEETC@/scripts/treemacs-single-file-git-status.py")))
+
+ (defconst treemacs--find-ignored-files.py
+ (if (member "treemacs-find-ignored-files.py" (directory-files treemacs-dir))
+ (treemacs-join-path treemacs-dir "treemacs-find-ignored-files.py")
+- (treemacs-join-path treemacs-dir "src/scripts/treemacs-find-ignored-files.py")))
++ (treemacs-join-path treemacs-dir "@SITEETC@/scripts/treemacs-find-ignored-files.py")))
+
+ (defvar treemacs--git-cache-max-size 60
+ "Maximum size for `treemacs--git-cache'.
diff --git a/app-emacs/treemacs/treemacs-2.10-r1.ebuild b/app-emacs/treemacs/treemacs-2.10-r1.ebuild
deleted file mode 100644
index ea3b8ab8544a..000000000000
--- a/app-emacs/treemacs/treemacs-2.10-r1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-NEED_EMACS=26.1
-
-inherit elisp
-
-DESCRIPTION="Tree style project file explorer"
-HOMEPAGE="https://github.com/Alexander-Miller/treemacs/"
-SRC_URI="https://github.com/Alexander-Miller/${PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-emacs/ace-window
- app-emacs/cfrs
- app-emacs/dash
- app-emacs/ht
- app-emacs/hydra
- app-emacs/pfuture
- app-emacs/s
-"
-BDEPEND="
- ${RDEPEND}
- test? ( app-emacs/buttercup )
-"
-
-DOCS=( Changelog.org Extensions.org README.org screenshots )
-PATCHES=( "${FILESDIR}"/${PN}-icons-icon-directory.patch )
-
-BYTECOMPFLAGS="-L . -L src/elisp"
-SITEFILE="50${PN}-gentoo.el"
-
-src_prepare() {
- elisp_src_prepare
-
- sed "s|@SITEETC@|${SITEETC}/${PN}|" -i src/elisp/${PN}-icons.el || die
-}
-
-src_compile() {
- elisp-compile src/elisp/*.el
-}
-
-src_test() {
- buttercup ${BYTECOMPFLAGS} -L test --traceback full || die
-}
-
-src_install() {
- elisp-install ${PN} src/elisp/*.el{,c}
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
-
- insinto ${SITEETC}/${PN}
- doins -r icons
-}
diff --git a/app-emacs/treemacs/treemacs-2.9.5-r1.ebuild b/app-emacs/treemacs/treemacs-2.9.5-r1.ebuild
deleted file mode 100644
index ea3b8ab8544a..000000000000
--- a/app-emacs/treemacs/treemacs-2.9.5-r1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-NEED_EMACS=26.1
-
-inherit elisp
-
-DESCRIPTION="Tree style project file explorer"
-HOMEPAGE="https://github.com/Alexander-Miller/treemacs/"
-SRC_URI="https://github.com/Alexander-Miller/${PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-emacs/ace-window
- app-emacs/cfrs
- app-emacs/dash
- app-emacs/ht
- app-emacs/hydra
- app-emacs/pfuture
- app-emacs/s
-"
-BDEPEND="
- ${RDEPEND}
- test? ( app-emacs/buttercup )
-"
-
-DOCS=( Changelog.org Extensions.org README.org screenshots )
-PATCHES=( "${FILESDIR}"/${PN}-icons-icon-directory.patch )
-
-BYTECOMPFLAGS="-L . -L src/elisp"
-SITEFILE="50${PN}-gentoo.el"
-
-src_prepare() {
- elisp_src_prepare
-
- sed "s|@SITEETC@|${SITEETC}/${PN}|" -i src/elisp/${PN}-icons.el || die
-}
-
-src_compile() {
- elisp-compile src/elisp/*.el
-}
-
-src_test() {
- buttercup ${BYTECOMPFLAGS} -L test --traceback full || die
-}
-
-src_install() {
- elisp-install ${PN} src/elisp/*.el{,c}
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
-
- insinto ${SITEETC}/${PN}
- doins -r icons
-}
diff --git a/app-emacs/treemacs/treemacs-3.1-r1.ebuild b/app-emacs/treemacs/treemacs-3.1-r1.ebuild
new file mode 100644
index 000000000000..5f04a6ad831c
--- /dev/null
+++ b/app-emacs/treemacs/treemacs-3.1-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 elisp
+
+DESCRIPTION="Tree style project file explorer"
+HOMEPAGE="https://github.com/Alexander-Miller/treemacs/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/Alexander-Miller/${PN}.git"
+else
+ SRC_URI="https://github.com/Alexander-Miller/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-editors/emacs-${NEED_EMACS}[svg]
+ app-emacs/ace-window
+ app-emacs/cfrs
+ app-emacs/dash
+ app-emacs/ht
+ app-emacs/hydra
+ app-emacs/pfuture
+ app-emacs/s
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+BYTECOMPFLAGS="-L . -L src/elisp"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.9.5-tests.patch"
+ "${FILESDIR}/${PN}-async-scripts.patch"
+ "${FILESDIR}/${PN}-icons-icon-directory.patch"
+)
+
+DOCS=( Changelog.org Extensions.org README.org screenshots )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests buttercup test
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ sed "s|@SITEETC@|${SITEETC}/${PN}|g" \
+ -i "src/elisp/${PN}-icons.el" \
+ -i "src/elisp/${PN}-async.el" || die
+}
+
+python_compile() {
+ python_optimize "${S}/src/scripts"
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ elisp-compile src/elisp/*.el
+}
+
+src_install() {
+ elisp-install "${PN}" src/elisp/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ insinto "${SITEETC}/${PN}"
+ doins -r icons
+ doins -r src/scripts
+}
diff --git a/app-emacs/treemacs/treemacs-3.1_p20240229.ebuild b/app-emacs/treemacs/treemacs-3.1_p20240229.ebuild
new file mode 100644
index 000000000000..b7337b3db652
--- /dev/null
+++ b/app-emacs/treemacs/treemacs-3.1_p20240229.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 elisp
+
+DESCRIPTION="Tree style project file explorer"
+HOMEPAGE="https://github.com/Alexander-Miller/treemacs/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/Alexander-Miller/${PN}.git"
+else
+ COMMIT_SHA=8c6df39f01a4d47fda2cc943645fa067f771b748
+ SRC_URI="https://github.com/Alexander-Miller/${PN}/archive/${COMMIT_SHA}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT_SHA}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-editors/emacs-${NEED_EMACS}[svg]
+ app-emacs/ace-window
+ app-emacs/cfrs
+ app-emacs/dash
+ app-emacs/ht
+ app-emacs/hydra
+ app-emacs/pfuture
+ app-emacs/s
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+BYTECOMPFLAGS="-L . -L src/elisp"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.9.5-tests.patch"
+ "${FILESDIR}/${PN}-async-scripts.patch"
+ "${FILESDIR}/${PN}-icons-icon-directory.patch"
+)
+
+DOCS=( Changelog.org Extensions.org README.org screenshots )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests buttercup test
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ sed -e "s|@SITEETC@|${SITEETC}/${PN}|g" \
+ -i "src/elisp/${PN}-icons.el" \
+ -i "src/elisp/${PN}-async.el" \
+ || die
+}
+
+python_compile() {
+ python_optimize "${S}/src/scripts"
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ elisp-compile src/elisp/*.el
+}
+
+src_install() {
+ elisp-install "${PN}" src/elisp/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ insinto "${SITEETC}/${PN}"
+ doins -r icons
+ doins -r src/scripts
+}