summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/treesit-auto')
-rw-r--r--app-emacs/treesit-auto/Manifest2
-rw-r--r--app-emacs/treesit-auto/metadata.xml16
-rw-r--r--app-emacs/treesit-auto/treesit-auto-1.0.3.ebuild28
-rw-r--r--app-emacs/treesit-auto/treesit-auto-1.0.5.ebuild28
4 files changed, 74 insertions, 0 deletions
diff --git a/app-emacs/treesit-auto/Manifest b/app-emacs/treesit-auto/Manifest
new file mode 100644
index 000000000000..85e744b74eb4
--- /dev/null
+++ b/app-emacs/treesit-auto/Manifest
@@ -0,0 +1,2 @@
+DIST treesit-auto-1.0.3.tar.gz 24841 BLAKE2B 89698a4810888d27f4c012301fb4f21ed1e9f8ce5cc774f1fa80add7257dbaaa3dbf23d32680542d6b54a841b1bb8d5ca81a6d07d5827a66139a21ab54492f35 SHA512 cd8c2fa23a154abdd883b82b8e465697acf48ce6ae2e0abc1aa8b7f99fd0e7f3266e13f79299fd5ac5be51402ef62c6f643d708ce290f6205a2e47a46b94cac1
+DIST treesit-auto-1.0.5.tar.gz 25069 BLAKE2B f565b49a9c929064ab6686a4fac1694aa197460579f5ee8c6304f002c5b18cb815bab7fab3a65fde069b402feb24754d4b66592ac6f32c4e7a9be42fb2493204 SHA512 c66d173304f0e9c09c5ee3c1c248192d06dff12da72676af7de481f6248eab714e0f6c7e69aa6b73a399422238d1c12676749d60c351214968977fabf24c70dd
diff --git a/app-emacs/treesit-auto/metadata.xml b/app-emacs/treesit-auto/metadata.xml
new file mode 100644
index 000000000000..95a10fb31665
--- /dev/null
+++ b/app-emacs/treesit-auto/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/renzmann/treesit-auto/issues/</bugs-to>
+ <remote-id type="github">renzmann/treesit-auto</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/treesit-auto/treesit-auto-1.0.3.ebuild b/app-emacs/treesit-auto/treesit-auto-1.0.3.ebuild
new file mode 100644
index 000000000000..f60b9db41667
--- /dev/null
+++ b/app-emacs/treesit-auto/treesit-auto-1.0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=29
+
+inherit elisp
+
+DESCRIPTION="Automatic installation, usage, fallback for tree-sitter modes in Emacs 29"
+HOMEPAGE="https://github.com/renzmann/treesit-auto/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/renzmann/${PN}.git"
+else
+ SRC_URI="https://github.com/renzmann/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/treesit-auto/treesit-auto-1.0.5.ebuild b/app-emacs/treesit-auto/treesit-auto-1.0.5.ebuild
new file mode 100644
index 000000000000..f60b9db41667
--- /dev/null
+++ b/app-emacs/treesit-auto/treesit-auto-1.0.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=29
+
+inherit elisp
+
+DESCRIPTION="Automatic installation, usage, fallback for tree-sitter modes in Emacs 29"
+HOMEPAGE="https://github.com/renzmann/treesit-auto/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/renzmann/${PN}.git"
+else
+ SRC_URI="https://github.com/renzmann/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"