summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/use-package/use-package-2.4.5.ebuild')
-rw-r--r--app-emacs/use-package/use-package-2.4.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/use-package/use-package-2.4.5.ebuild b/app-emacs/use-package/use-package-2.4.5.ebuild
new file mode 100644
index 000000000000..58a5752c9a36
--- /dev/null
+++ b/app-emacs/use-package/use-package-2.4.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE: This package provides all "use-package" Emacs Lisp libraries except
+# "bind-chord" and "bind-key" which are split into their own packages.
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Declaration macro for simplifying your Emacs configuration"
+HOMEPAGE="https://github.com/jwiegley/use-package/
+ https://elpa.gnu.org/packages/use-package.html"
+SRC_URI="https://dev.gentoo.org/~xgqt/distfiles/repackaged/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc x86"
+
+RDEPEND="
+ app-emacs/bind-chord
+ app-emacs/bind-key
+ app-emacs/diminish
+ app-emacs/system-packages
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-require-diminish.patch )
+
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"