summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/vhdl-mode/vhdl-mode-3.39.2.ebuild')
-rw-r--r--app-emacs/vhdl-mode/vhdl-mode-3.39.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/vhdl-mode/vhdl-mode-3.39.2.ebuild b/app-emacs/vhdl-mode/vhdl-mode-3.39.2.ebuild
new file mode 100644
index 000000000000..8c9ebd57c1b7
--- /dev/null
+++ b/app-emacs/vhdl-mode/vhdl-mode-3.39.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="VHDL-mode for Emacs"
+HOMEPAGE="https://iis-people.ee.ethz.ch/~zimmi/emacs/vhdl-mode.html"
+SRC_URI="https://iis-people.ee.ethz.ch/~zimmi/emacs/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+PATCHES=( "${FILESDIR}"/${PN}-info-dir-gentoo.patch )
+ELISP_REMOVE="site-start.*"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="ChangeLog README"
+
+src_install() {
+ elisp_src_install
+ doinfo vhdl-mode.info
+}