summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/vhdl-mode/vhdl-mode-3.39.3.ebuild')
-rw-r--r--app-emacs/vhdl-mode/vhdl-mode-3.39.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emacs/vhdl-mode/vhdl-mode-3.39.3.ebuild b/app-emacs/vhdl-mode/vhdl-mode-3.39.3.ebuild
new file mode 100644
index 000000000000..a67aca050578
--- /dev/null
+++ b/app-emacs/vhdl-mode/vhdl-mode-3.39.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="VHDL-mode for Emacs"
+HOMEPAGE="https://iis-people.ee.ethz.ch/~zimmi/emacs/vhdl-mode.html"
+SRC_URI="https://iis-people.ee.ethz.ch/~zimmi/emacs/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+ELISP_REMOVE="site-start.*"
+PATCHES=( "${FILESDIR}/${PN}-info-dir-gentoo.patch" )
+
+DOCS="ChangeLog README"
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+
+ doinfo vhdl-mode.info
+}