summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/vue-html-mode/vue-html-mode-0.2.ebuild')
-rw-r--r--app-emacs/vue-html-mode/vue-html-mode-0.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/vue-html-mode/vue-html-mode-0.2.ebuild b/app-emacs/vue-html-mode/vue-html-mode-0.2.ebuild
new file mode 100644
index 000000000000..7154d2eeb75d
--- /dev/null
+++ b/app-emacs/vue-html-mode/vue-html-mode-0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Major Emacs mode for editing Vue.js templates"
+HOMEPAGE="https://github.com/AdamNiederer/vue-html-mode/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/AdamNiederer/${PN}.git"
+else
+ SRC_URI="https://github.com/AdamNiederer/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"