summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/yasnippet')
-rw-r--r--app-emacs/yasnippet/Manifest2
-rw-r--r--app-emacs/yasnippet/yasnippet-0.14.0.ebuild (renamed from app-emacs/yasnippet/yasnippet-0.13.0.ebuild)14
2 files changed, 8 insertions, 8 deletions
diff --git a/app-emacs/yasnippet/Manifest b/app-emacs/yasnippet/Manifest
index a590a9403f48..19bc254c6b2b 100644
--- a/app-emacs/yasnippet/Manifest
+++ b/app-emacs/yasnippet/Manifest
@@ -1 +1 @@
-DIST yasnippet-0.13.0.tar.gz 577330 BLAKE2B 21830c0a2e99d7669093c16f527debb4921e96aad006887ec1c7e35da58745721658417f1aec96ea78ba4dc5f3951c857848fce67e6d2ff7f255d4aea5687ab9 SHA512 73b111f72e98c4183764cef08ddfaa861dba49f171f96026b074bf62a7aa5e2d8529f616805ba386dd4157b675da953784d5bcd832d6015ce1b72e9c240988c5
+DIST yasnippet-0.14.0.tar.gz 581053 BLAKE2B efae02939d0174724803819fb9a47a414acad3b1d58da91d4f35c42c02282db9773f4f3caa020d01c2d87de741d3c60b39e1406b6ff7b3e5310ed4efc477d635 SHA512 c7f704187b3c700f8ea9e0205941d7a32602b6994307007cb83aa984ccf7e7e37be9589277a56c294703eab82ee4b1dffae7040f2e175e7d56cda5ef3c70eb39
diff --git a/app-emacs/yasnippet/yasnippet-0.13.0.ebuild b/app-emacs/yasnippet/yasnippet-0.14.0.ebuild
index e6ba47b23dc4..cce198a2a7fc 100644
--- a/app-emacs/yasnippet/yasnippet-0.13.0.ebuild
+++ b/app-emacs/yasnippet/yasnippet-0.14.0.ebuild
@@ -1,20 +1,20 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit elisp readme.gentoo-r1
DESCRIPTION="Yet another snippet extension for Emacs"
-HOMEPAGE="http://joaotavora.github.com/yasnippet/"
+HOMEPAGE="https://joaotavora.github.io/yasnippet/"
SRC_URI="https://github.com/joaotavora/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
IUSE="doc"
-SITEFILE="50${PN}-gentoo-${PV}.el"
+SITEFILE="50${PN}-gentoo-0.13.0.el"
src_test() {
${EMACS} ${EMACSFLAGS} -L . -l yasnippet-tests \
@@ -22,12 +22,12 @@ src_test() {
}
src_install() {
- elisp-install ${PN} yasnippet.el{,c} yasnippet-debug.el{,c}
+ elisp-install ${PN} yasnippet.{el,elc} yasnippet-debug.{el,elc}
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
dodoc CONTRIBUTING.md NEWS README.mdown
use doc && dodoc -r doc/*
- DOC_CONTENTS="Add the following to your ~/.emacs to use YASnippet:
+ local DOC_CONTENTS="Add the following to your ~/.emacs to use YASnippet:
\n\t(require 'yasnippet)
\n\t(yas-global-mode 1)
\n\nYASnippet no longer bundles snippets directly. Install the package