summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/async/Manifest1
-rw-r--r--app-emacs/async/async-1.9.3.ebuild24
-rw-r--r--app-emacs/async/files/50async-gentoo.el2
-rw-r--r--app-emacs/async/metadata.xml12
4 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/async/Manifest b/app-emacs/async/Manifest
new file mode 100644
index 000000000000..6355cabf490c
--- /dev/null
+++ b/app-emacs/async/Manifest
@@ -0,0 +1 @@
+DIST emacs-async-1.9.3.tar.gz 14394 BLAKE2B dd6a98e61027dae2fa9ebb8e20f81a2d2debff1e990e57084a747ea815d1e615dc0e4b8fe5fcdc1f562c0f02780951121f4a67b26584f4519290413da05dc1e9 SHA512 ecbbb6614882df8a58a3440a78867e6cd19ae448e2e897b27d6aeaf5e5a648dcedbac64afbfd6240b7e68c533c685060f453051ef9a85d9d4cca6831fbf2c1dd
diff --git a/app-emacs/async/async-1.9.3.ebuild b/app-emacs/async/async-1.9.3.ebuild
new file mode 100644
index 000000000000..c59fc3c4339d
--- /dev/null
+++ b/app-emacs/async/async-1.9.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+MY_P="emacs-async-${PV}"
+DESCRIPTION="Simple library for asynchronous processing in Emacs"
+HOMEPAGE="https://github.com/jwiegley/emacs-async"
+SRC_URI="https://github.com/jwiegley/emacs-async/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/async/files/50async-gentoo.el b/app-emacs/async/files/50async-gentoo.el
new file mode 100644
index 000000000000..538bd0c8d452
--- /dev/null
+++ b/app-emacs/async/files/50async-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/async-autoloads" nil t)
diff --git a/app-emacs/async/metadata.xml b/app-emacs/async/metadata.xml
new file mode 100644
index 000000000000..0b9a819893e6
--- /dev/null
+++ b/app-emacs/async/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">jwiegley/emacs-async</remote-id>
+</upstream>
+</pkgmetadata>