summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/bochs')
-rw-r--r--app-emulation/bochs/Manifest2
-rw-r--r--app-emulation/bochs/bochs-2.6.10.ebuild5
-rw-r--r--app-emulation/bochs/bochs-2.7.ebuild (renamed from app-emulation/bochs/bochs-2.6.9.ebuild)32
-rw-r--r--app-emulation/bochs/bochs-9999.ebuild29
-rw-r--r--app-emulation/bochs/metadata.xml2
5 files changed, 33 insertions, 37 deletions
diff --git a/app-emulation/bochs/Manifest b/app-emulation/bochs/Manifest
index f01ca66acfe9..37499a1033c0 100644
--- a/app-emulation/bochs/Manifest
+++ b/app-emulation/bochs/Manifest
@@ -1,2 +1,2 @@
DIST bochs-2.6.10.tar.gz 5282176 BLAKE2B 9f75d5afd6bad9f91eb18dc0bd5c9ed998bf12077d3e8d944769055f0def1eed019756346071d3809d492c54177ec798e739259ee13f67ff4760744377dc877c SHA512 eff422cadc3e0db7a47c4015a59ca0fa8caf88ed3026706c1f766e802449ec8e4798e5f147a583e1cfbbc578f71da8800542c0e1f4d04bc2dea77955855e8689
-DIST bochs-2.6.9.tar.gz 5169187 BLAKE2B 49824a96a48294d8d507bc15128103e9c2839515554657d282c7c9533aa299cb6289581e760ea40a6c659adfb7ebdac0d273d2a9e7b598c95b145d65e8cdc977 SHA512 dfecf3a1bad07f06c2f7bb989d146e4a8eaeca493b598d415f5a4aec2a85eb5524ba417422157608c8b0828832611df487c6923c8f4ad98a147ac089fc514c46
+DIST bochs-2.7.tar.gz 5298413 BLAKE2B 570ac0fec74b8e79a8e78d32a1a8655b8e3a202a3247407a45b66991598486bd6c566711a1f8e18e717d4f2119b82ae03bf4a792eebdd25a6e7ca4dedb3901ab SHA512 d43bd557316dc370ba1c317f5c3292f724460515db01316614b2d585b2760120cadd1d27a286083ac3e6f57466ed889959abd7fe960c219c149dab9a053c6967
diff --git a/app-emulation/bochs/bochs-2.6.10.ebuild b/app-emulation/bochs/bochs-2.6.10.ebuild
index c4f9fde9ba89..da275ab22599 100644
--- a/app-emulation/bochs/bochs-2.6.10.ebuild
+++ b/app-emulation/bochs/bochs-2.6.10.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="LGPL-ed pc emulator"
HOMEPAGE="http://bochs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/bochs/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
@@ -33,7 +33,6 @@ DEPEND="${RDEPEND}
"
BDEPEND="
doc? ( app-text/docbook-sgml-utils )
- sys-apps/sed
>=app-text/opensp-1.5
"
diff --git a/app-emulation/bochs/bochs-2.6.9.ebuild b/app-emulation/bochs/bochs-2.7.ebuild
index 80e103e7f589..cbfb55b92ffe 100644
--- a/app-emulation/bochs/bochs-2.6.9.ebuild
+++ b/app-emulation/bochs/bochs-2.7.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="LGPL-ed pc emulator"
HOMEPAGE="http://bochs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/bochs/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="3dnow avx debugger doc gdb ncurses readline svga sdl +smp vnc X +x86-64"
+IUSE="3dnow avx debugger doc gdb ncurses readline sdl +smp vnc X +x86-64"
REQUIRED_USE="
avx? ( x86-64 )
gdb? ( !debugger !smp )
@@ -19,24 +19,27 @@ REQUIRED_USE="
"
RDEPEND="
- X? ( x11-libs/libICE
+ ncurses? ( sys-libs/ncurses:= )
+ readline? ( sys-libs/readline:= )
+ sdl? ( media-libs/libsdl )
+ X? (
+ x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
- x11-libs/libXpm )
- sdl? ( media-libs/libsdl )
- svga? ( media-libs/svgalib )
- readline? ( sys-libs/readline:= )
- ncurses? ( sys-libs/ncurses:= )
+ x11-libs/libXpm
+ )
"
DEPEND="${RDEPEND}
- doc? ( app-text/docbook-sgml-utils )
X? ( x11-base/xorg-proto )
- sys-apps/sed
+"
+BDEPEND="
>=app-text/opensp-1.5
+ doc? ( app-text/docbook-sgml-utils )
"
src_prepare() {
default
+
sed -i "s:^docdir.*:docdir = ${EPREFIX}/usr/share/doc/${PF}:" \
Makefile.in || die
}
@@ -48,7 +51,6 @@ src_configure() {
--enable-cdrom \
--enable-clgd54xx \
--enable-cpu-level=6 \
- --enable-disasm \
--enable-e1000 \
--enable-gameport \
--enable-iodebug \
@@ -75,9 +77,7 @@ src_configure() {
$(use_enable x86-64) \
$(use_with ncurses term) \
$(use_with sdl) \
- $(use_with svga) \
$(use_with vnc rfb) \
$(use_with X x) \
- $(use_with X x11) \
- ${myconf}
+ $(use_with X x11)
}
diff --git a/app-emulation/bochs/bochs-9999.ebuild b/app-emulation/bochs/bochs-9999.ebuild
index fa7208ddc58f..280702aad06e 100644
--- a/app-emulation/bochs/bochs-9999.ebuild
+++ b/app-emulation/bochs/bochs-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,14 +7,13 @@ inherit subversion
DESCRIPTION="LGPL-ed pc emulator"
HOMEPAGE="http://bochs.sourceforge.net/"
-#SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz"
+#SRC_URI="https://downloads.sourceforge.net/bochs/${P}.tar.gz"
ESVN_REPO_URI="svn://svn.code.sf.net/p/bochs/code/trunk/bochs"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS=""
-IUSE="3dnow avx debugger doc gdb ncurses readline svga sdl +smp vnc X +x86-64"
+IUSE="3dnow avx debugger doc gdb ncurses readline sdl +smp vnc X +x86-64"
REQUIRED_USE="
avx? ( x86-64 )
gdb? ( !debugger !smp )
@@ -22,26 +21,27 @@ REQUIRED_USE="
"
RDEPEND="
- X? ( x11-libs/libICE
+ ncurses? ( sys-libs/ncurses:= )
+ readline? ( sys-libs/readline:= )
+ sdl? ( media-libs/libsdl )
+ X? (
+ x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
- x11-libs/libXpm )
- sdl? ( media-libs/libsdl )
- svga? ( media-libs/svgalib )
- readline? ( sys-libs/readline:= )
- ncurses? ( sys-libs/ncurses:= )
+ x11-libs/libXpm
+ )
"
DEPEND="${RDEPEND}
X? ( x11-base/xorg-proto )
"
BDEPEND="
- doc? ( app-text/docbook-sgml-utils )
- sys-apps/sed
>=app-text/opensp-1.5
+ doc? ( app-text/docbook-sgml-utils )
"
src_prepare() {
default
+
sed -i "s:^docdir.*:docdir = ${EPREFIX}/usr/share/doc/${PF}:" \
Makefile.in || die
}
@@ -53,7 +53,6 @@ src_configure() {
--enable-cdrom \
--enable-clgd54xx \
--enable-cpu-level=6 \
- --enable-disasm \
--enable-e1000 \
--enable-gameport \
--enable-iodebug \
@@ -80,9 +79,7 @@ src_configure() {
$(use_enable x86-64) \
$(use_with ncurses term) \
$(use_with sdl) \
- $(use_with svga) \
$(use_with vnc rfb) \
$(use_with X x) \
- $(use_with X x11) \
- ${myconf}
+ $(use_with X x11)
}
diff --git a/app-emulation/bochs/metadata.xml b/app-emulation/bochs/metadata.xml
index 4e953a303483..41f8336a25e7 100644
--- a/app-emulation/bochs/metadata.xml
+++ b/app-emulation/bochs/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>lu_zero@gentoo.org</email>