summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/docker-compose/docker-compose-1.24.0.ebuild')
-rw-r--r--app-emulation/docker-compose/docker-compose-1.24.0.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/app-emulation/docker-compose/docker-compose-1.24.0.ebuild b/app-emulation/docker-compose/docker-compose-1.24.0.ebuild
index 231ec1bd9f17..3e0bfb04269c 100644
--- a/app-emulation/docker-compose/docker-compose-1.24.0.ebuild
+++ b/app-emulation/docker-compose/docker-compose-1.24.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
inherit bash-completion-r1 distutils-r1
@@ -29,15 +29,11 @@ RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/requests-2.18.1[${PYTHON_USEDEP}]
>=dev-python/six-1.3.0[${PYTHON_USEDEP}]
>=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
- >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )"
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? ( <dev-python/pytest-4[${PYTHON_USEDEP}]
- <dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' ) )"
+ <dev-python/pyyaml-5.1[${PYTHON_USEDEP}] )"
S="${WORKDIR}/compose-${PV}"