summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/docker-compose/files/docker-compose-1.23.2-setup-py.patch')
-rw-r--r--app-emulation/docker-compose/files/docker-compose-1.23.2-setup-py.patch58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/files/docker-compose-1.23.2-setup-py.patch b/app-emulation/docker-compose/files/docker-compose-1.23.2-setup-py.patch
new file mode 100644
index 000000000000..193ece1c09f9
--- /dev/null
+++ b/app-emulation/docker-compose/files/docker-compose-1.23.2-setup-py.patch
@@ -0,0 +1,58 @@
+From 15b1ac5bfeb0ca2a8524dae10db7573b4efacba9 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Fri, 10 May 2019 23:54:14 +0200
+Subject: [PATCH] setup.py: Drop generic upper version boundaries
+
+---
+ setup.py | 26 +++++++++++++-------------
+ 1 file changed, 13 insertions(+), 13 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 22dafdb..00167ce 100644
+--- a/setup.py
++++ b/setup.py
+@@ -30,16 +30,16 @@ def find_version(*file_paths):
+
+
+ install_requires = [
+- 'cached-property >= 1.2.0, < 2',
+- 'docopt >= 0.6.1, < 0.7',
+- 'PyYAML >= 3.10, < 4',
+- 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0, < 2.21',
+- 'texttable >= 0.9.0, < 0.10',
+- 'websocket-client >= 0.32.0, < 1.0',
+- 'docker >= 3.6.0, < 4.0',
+- 'dockerpty >= 0.4.1, < 0.5',
+- 'six >= 1.3.0, < 2',
+- 'jsonschema >= 2.5.1, < 3',
++ 'cached-property >= 1.2.0',
++ 'docopt >= 0.6.1',
++ 'PyYAML >= 3.10',
++ 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0',
++ 'texttable >= 0.9.0',
++ 'websocket-client >= 0.32.0',
++ 'docker >= 3.6.0',
++ 'dockerpty >= 0.4.1',
++ 'six >= 1.3.0',
++ 'jsonschema >= 2.5.1',
+ ]
+
+
+@@ -52,11 +52,11 @@ if sys.version_info[:2] < (3, 4):
+ tests_require.append('mock >= 1.0.1')
+
+ extras_require = {
+- ':python_version < "3.4"': ['enum34 >= 1.0.4, < 2'],
++ ':python_version < "3.4"': ['enum34 >= 1.0.4'],
+ ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5'],
+ ':python_version < "3.3"': ['ipaddress >= 1.0.16'],
+- ':sys_platform == "win32"': ['colorama >= 0.4, < 0.5'],
+- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
++ ':sys_platform == "win32"': ['colorama >= 0.4'],
++ 'socks': ['PySocks >= 1.5.6, != 1.5.7'],
+ }
+
+
+--
+2.21.0
+