summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/docker-machine-kvm/docker-machine-kvm-0.10.0.ebuild')
-rw-r--r--app-emulation/docker-machine-kvm/docker-machine-kvm-0.10.0.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/app-emulation/docker-machine-kvm/docker-machine-kvm-0.10.0.ebuild b/app-emulation/docker-machine-kvm/docker-machine-kvm-0.10.0.ebuild
index b9a0908fcb3c..1a254c9e6627 100644
--- a/app-emulation/docker-machine-kvm/docker-machine-kvm-0.10.0.ebuild
+++ b/app-emulation/docker-machine-kvm/docker-machine-kvm-0.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,7 +15,7 @@ KEYWORDS="~amd64"
DESCRIPTION="KVM driver for docker-machine"
HOMEPAGE="https://github.com/dhiltgen/docker-machine-kvm"
-LICENSE="Apache-2.0"
+LICENSE="Apache-2.0 BSD CC-BY-SA-4.0 MIT MPL-2.0 ZLIB"
SLOT="0"
IUSE=""
COMMON_DEPEND="app-emulation/libvirt:=[qemu,virt-network]"
@@ -26,10 +26,16 @@ RDEPEND="${COMMON_DEPEND}"
SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
${EGO_VENDOR_URI}"
+src_prepare() {
+ # go build -i is no longer supported #893080
+ sed -e 's: -i::' -i src/github.com/dhiltgen/docker-machine-kvm/cmd/docker-machine-driver-kvm/Makefile || die
+ default
+}
+
src_compile() {
export GOPATH=${S}
cd "${S}"/src/${EGO_PN}/cmd/${PN/kvm/driver-kvm} || die
- emake build || die
+ emake build
}
src_install() {