summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/domi/domi-20060816.ebuild')
-rw-r--r--app-emulation/domi/domi-20060816.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emulation/domi/domi-20060816.ebuild b/app-emulation/domi/domi-20060816.ebuild
new file mode 100644
index 000000000000..5384bc754b3f
--- /dev/null
+++ b/app-emulation/domi/domi-20060816.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+DESCRIPTION="Scripts for building Xen domains"
+HOMEPAGE="http://www.bytesex.org"
+EXTRA_VERSION="153213"
+SRC_URI="http://dl.bytesex.org/cvs-snapshots/${P}-${EXTRA_VERSION}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="app-emulation/xen-tools
+ app-arch/rpm
+ sys-block/parted
+ sys-apps/yum
+ sys-fs/lvm2
+ sys-fs/multipath-tools"
+# there are some other depends we may need depending on the target system
+# these packages aren't in gentoo yet. feel free to submit ebuilds via bugzilla.
+# y2pmsh
+RESTRICT="test"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e 's:/dev/loop\$:/dev/loop/\$:' "${S}"/domi
+ cd "${S}"
+ epatch "${FILESDIR}"/fix_install_links.patch
+}
+
+src_install() {
+ einstall || die
+ insinto /etc
+ doins "${FILESDIR}"/domi.conf || die
+}