summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild')
-rw-r--r--app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild74
1 files changed, 45 insertions, 29 deletions
diff --git a/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild b/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild
index 6eb911c30a14..33bcb2602637 100644
--- a/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild
+++ b/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 2002-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI="7"
-inherit autotools eutils flag-o-matic pax-utils toolchain-funcs
+inherit autotools flag-o-matic pax-utils toolchain-funcs
P_FD="dosemu-freedos-1.0-bin"
COMMIT="15cfb41ff20a052769d753c3262c57ecb050ad71"
@@ -12,36 +12,38 @@ COMMIT="15cfb41ff20a052769d753c3262c57ecb050ad71"
DESCRIPTION="DOS Emulator"
HOMEPAGE="http://www.dosemu.org/"
-SRC_URI="mirror://sourceforge/dosemu/${P_FD}.tgz
- https://dev.gentoo.org/~slyfox/distfiles/${P}.zip"
+SRC_URI="https://downloads.sourceforge.net/dosemu/${P_FD}.tgz
+ https://dev.gentoo.org/~sam/distfiles/${P}.zip"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* amd64 x86"
-IUSE="X svga gpm debug alsa sndfile fluidsynth"
+IUSE="X alsa debug fluidsynth gpm svga"
-RDEPEND="X? ( x11-libs/libX11
- x11-libs/libXxf86vm
- x11-libs/libXau
- x11-libs/libXext
- x11-libs/libXdmcp
- x11-apps/xset
- x11-apps/xlsfonts
+BDEPEND="app-arch/unzip
+ X? (
x11-apps/bdftopcf
- >=x11-apps/mkfontscale-1.2.0 )
- svga? ( media-libs/svgalib )
- gpm? ( sys-libs/gpm )
+ >=x11-apps/mkfontscale-1.2.0
+ )"
+COMMON_DEPEND="media-libs/libsdl
+ >=sys-libs/slang-1.4
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXxf86vm
+ )
alsa? ( media-libs/alsa-lib )
- sndfile? ( media-libs/libsndfile )
- fluidsynth? ( media-sound/fluidsynth
- media-sound/fluid-soundfont )
- media-libs/libsdl
- >=sys-libs/slang-1.4"
-
-DEPEND="${RDEPEND}
- app-arch/unzip
- X? ( x11-base/xorg-proto )
- >=sys-devel/autoconf-2.57"
+ fluidsynth? (
+ media-sound/fluid-soundfont
+ media-sound/fluidsynth
+ )
+ gpm? ( sys-libs/gpm )
+ svga? ( media-libs/svgalib )"
+# sndfile? ( media-libs/libsndfile )
+DEPEND="${COMMON_DEPEND}
+ X? ( x11-base/xorg-proto )"
+RDEPEND="${COMMON_DEPEND}
+ X? ( x11-apps/xset )"
S="${WORKDIR}/${PN}-code-${COMMIT}"
@@ -52,8 +54,17 @@ PATCHES=(
"${FILESDIR}"/${P}-flex-2.6.3.patch
"${FILESDIR}"/${P}-ia16-ldflags.patch
"${FILESDIR}"/${P}-fix-inline.patch
+ "${FILESDIR}"/${P}-lto.patch
+ "${FILESDIR}"/${P}-as.patch
+ "${FILESDIR}"/${P}-nm.patch
)
+pkg_pretend() {
+ if tc-is-clang; then
+ die "${P} does not work on clang due to missing 16-bit assembly support: https://bugs.gentoo.org/729240. Please try gcc."
+ fi
+}
+
src_prepare() {
default
@@ -79,21 +90,26 @@ src_configure() {
fi
fi
+ # sndfile support is unconditionally disabled in src/plugin/sndfile/snd_o_wav.c
+ # CPP has to be set explicitly to workaround autoconf-2.69
+ # CPP detection (fixed in 2.70). bug #762748.
econf $(use_with X x) \
$(use_with svga svgalib) \
$(use_enable debug) \
$(use_with gpm) \
$(use_with alsa) \
- $(use_with sndfile) \
$(use_with fluidsynth) \
+ --without-sndfile \
--with-fdtarball="${DISTDIR}"/${P_FD}.tgz \
--sysconfdir="${EPREFIX}"/etc/dosemu/ \
--with-docdir="${EPREFIX}"/usr/share/doc/${PF} \
- IA16_LDFLAGS_EXTRA=${nopie_flag}
+ IA16_LDFLAGS_EXTRA=${nopie_flag} \
+ CPP="$(tc-getCPP)"
}
src_compile() {
- emake AR=$(tc-getAR)
+ # src/makefile.common is written manually, uses AR=ar
+ emake AR="$(tc-getAR)"
}
src_install() {