summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/faudio')
-rw-r--r--app-emulation/faudio/Manifest4
-rw-r--r--app-emulation/faudio/faudio-21.01.ebuild95
-rw-r--r--app-emulation/faudio/faudio-23.02.ebuild37
-rw-r--r--app-emulation/faudio/faudio-23.10.ebuild37
-rw-r--r--app-emulation/faudio/faudio-24.02.ebuild37
-rw-r--r--app-emulation/faudio/faudio-9999.ebuild95
-rw-r--r--app-emulation/faudio/files/faudio.pc11
-rw-r--r--app-emulation/faudio/metadata.xml17
8 files changed, 117 insertions, 216 deletions
diff --git a/app-emulation/faudio/Manifest b/app-emulation/faudio/Manifest
index 900869b8ed3d..8309fa7609e5 100644
--- a/app-emulation/faudio/Manifest
+++ b/app-emulation/faudio/Manifest
@@ -1 +1,3 @@
-DIST FAudio-21.01.tar.gz 1134752 BLAKE2B 3acf80172744bfdc6fb44e373ee2a159ed4d49713fec38a8c6447d66c345445a435e1eb1656552289a634e3a628cfcf7df979a2d155edca1aef0c0334629424e SHA512 69405a28fdf3ff5026992bdd1d40d61653b834dac3ef2697a0e794deac2fa6257fe74b19d2fe225ce25a1ae3caec7082106f5ab6ea6109cc61e520b903d35b80
+DIST faudio-23.02.tar.gz 1111012 BLAKE2B c776a5b882697fbbed894f129165600b1aad8b303254e9ecbf6111fff71581491b484681a71d377854077dfc23b99d1217e5322bdd9923caf4471cc0bc2ca0f2 SHA512 d83adca1f1e42b1c7d63dad30886b58a914ac9a5a254f26d3fdb2386776840e3c40b22a8dd9c7172e6c97b0db989f919fd2ebeac2ec00075a8136ec9120bc390
+DIST faudio-23.10.tar.gz 1120033 BLAKE2B 2f064ba71386db69870b4e523625c421b2062f3584f834b55367dd675a1a61509831b036ed2e459cd2ea247e2b56401142bf73b6e828bd2ff4699623ba0d453f SHA512 cc17c1c3950267a8cc69d0a263deef1d80e8bb9f658f1c2cd1c137bccac1d2be234d17f9b790bbe8bd1ba9da7e13676d3d38e328399d5a706f6ed502365de9ba
+DIST faudio-24.02.tar.gz 1122131 BLAKE2B 5ace47c679e7c35fc13157c1bdf6d8a8080fd9e3516f9007628875a2c67d1d2aab63404261c28aadcb33305c196c6e96ba8045d50e42d7f79d47ee0696bdb068 SHA512 de48196bc9d93784d2f2ce20c7aba83066a8a7653781104eb3b15fa8206e54875d5c555dab4c6fb763cf41fd6ec733e71b6bba53c8cafd98af99ea9eb0a3d666
diff --git a/app-emulation/faudio/faudio-21.01.ebuild b/app-emulation/faudio/faudio-21.01.ebuild
deleted file mode 100644
index de43fa552706..000000000000
--- a/app-emulation/faudio/faudio-21.01.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# shellcheck disable=SC2034
-EAPI=7
-
-CMAKE_ECLASS=cmake
-CMAKE_MAKEFILE_GENERATOR="emake"
-MULTILIB_COMPAT=( abi_x86_{32,64} )
-
-inherit cmake-multilib virtualx multilib-build
-
-FAUDIO_PN="FAudio"
-FAUDIO_PV="${PV}"
-FAUDIO_P="${FAUDIO_PN}-${FAUDIO_PV}"
-
-if [[ "${PV}" == "9999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/FNA-XNA/${FAUDIO_PN}.git"
-else
- SRC_URI="https://github.com/FNA-XNA/${FAUDIO_PN}/archive/${FAUDIO_PV}.tar.gz -> ${FAUDIO_P}.tar.gz"
- KEYWORDS="amd64 x86"
- S="${WORKDIR}/${FAUDIO_P}"
-fi
-
-DESCRIPTION="FAudio - Accuracy-focused XAudio reimplementation for open platforms"
-HOMEPAGE="https://fna-xna.github.io/"
-LICENSE="ZLIB"
-SLOT="0"
-
-IUSE="+abi_x86_32 +abi_x86_64 debug dumpvoices gstreamer xnasong test utils"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )"
-
-DEPEND="
- >=media-libs/libsdl2-2.0.9[sound,${MULTILIB_USEDEP}]
- gstreamer? (
- media-libs/gstreamer:1.0[${MULTILIB_USEDEP}]
- media-libs/gst-plugins-base:1.0[${MULTILIB_USEDEP}]
- )
-"
-RDEPEND="${DEPEND}"
-
-multilib_src_configure() {
- local mycmakeargs=(
- "-DCMAKE_INSTALL_BINDIR=bin"
- "-DCMAKE_INSTALL_INCLUDEDIR=include/${FAUDIO_PN}"
- "-DCMAKE_INSTALL_LIBDIR=$(get_libdir)"
- "-DCMAKE_BUILD_TYPE=$(usex debug Debug Release)"
- "-DFORCE_ENABLE_DEBUGCONFIGURATION=$(usex debug ON OFF)"
- "-DBUILD_TESTS=$(usex test ON OFF)"
- "-DBUILD_UTILS=$(usex utils ON OFF)"
- "-DDUMP_VOICES=$(usex dumpvoices ON OFF)"
- "-DGSTREAMER=$(usex gstreamer ON OFF)"
- "-DXNASONG=$(usex xnasong ON OFF)"
- )
- cmake_src_configure
-}
-
-src_configure() {
- cmake-multilib_src_configure
-}
-
-multilib_src_compile() {
- cmake_build
- emake -C "${BUILD_DIR}" all
-}
-
-multilib_src_install() {
- # FIXME: do we want to install the FAudio tools?
- cmake_src_install
-
- sed -e "s@%LIB%@$(get_libdir)@g" -e "s@%PREFIX%@${EPREFIX}/usr@g" \
- "${FILESDIR}/faudio.pc" > "${T}/faudio.pc" \
- || die "sed failed"
- insinto "/usr/$(get_libdir)/pkgconfig"
- doins "${T}/faudio.pc"
-
- if use test; then
- mkdir -p "${T}/$(get_libdir)" || die
- cp "${BUILD_DIR}/faudio_tests" "${T}/$(get_libdir)/" || die "cp failed"
- fi
-}
-
-faudio_test() {
- XDG_RUNTIME_DIR="/run/user/0" virtx "${T}/$(get_libdir)/faudio_tests"
-}
-
-pkg_postinst() {
- use test || return
-
- # FIXME: FAudio tests are broken and also don't appear to work
- # in the Portage sandbox.
- multilib_foreach_abi faudio_test
-}
diff --git a/app-emulation/faudio/faudio-23.02.ebuild b/app-emulation/faudio/faudio-23.02.ebuild
new file mode 100644
index 000000000000..b009b323807d
--- /dev/null
+++ b/app-emulation/faudio/faudio-23.02.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Accuracy-focused XAudio reimplementation for open platforms"
+HOMEPAGE="https://fna-xna.github.io/"
+SRC_URI="https://github.com/FNA-XNA/FAudio/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FAudio-${PV}"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug dumpvoices test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="media-libs/libsdl2[sound]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ append-cppflags -D_DEFAULT_SOURCE # usleep() in tests
+ use debug || append-cppflags -DFAUDIO_DISABLE_DEBUGCONFIGURATION
+
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ -DDUMP_VOICES=$(usex dumpvoices)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ einfo "Running faudio_tests, this may take some time without output..."
+ SDL_AUDIODRIVER=dummy "${BUILD_DIR}"/faudio_tests || die
+}
diff --git a/app-emulation/faudio/faudio-23.10.ebuild b/app-emulation/faudio/faudio-23.10.ebuild
new file mode 100644
index 000000000000..e372ae484496
--- /dev/null
+++ b/app-emulation/faudio/faudio-23.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Accuracy-focused XAudio reimplementation for open platforms"
+HOMEPAGE="https://fna-xna.github.io/"
+SRC_URI="https://github.com/FNA-XNA/FAudio/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FAudio-${PV}"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug dumpvoices test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="media-libs/libsdl2[sound]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ append-cppflags -D_DEFAULT_SOURCE # usleep() in tests
+ use debug || append-cppflags -DFAUDIO_DISABLE_DEBUGCONFIGURATION
+
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ -DDUMP_VOICES=$(usex dumpvoices)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ einfo "Running faudio_tests, this may take some time without output..."
+ SDL_AUDIODRIVER=dummy "${BUILD_DIR}"/faudio_tests || die
+}
diff --git a/app-emulation/faudio/faudio-24.02.ebuild b/app-emulation/faudio/faudio-24.02.ebuild
new file mode 100644
index 000000000000..e372ae484496
--- /dev/null
+++ b/app-emulation/faudio/faudio-24.02.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Accuracy-focused XAudio reimplementation for open platforms"
+HOMEPAGE="https://fna-xna.github.io/"
+SRC_URI="https://github.com/FNA-XNA/FAudio/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FAudio-${PV}"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug dumpvoices test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="media-libs/libsdl2[sound]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ append-cppflags -D_DEFAULT_SOURCE # usleep() in tests
+ use debug || append-cppflags -DFAUDIO_DISABLE_DEBUGCONFIGURATION
+
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ -DDUMP_VOICES=$(usex dumpvoices)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ einfo "Running faudio_tests, this may take some time without output..."
+ SDL_AUDIODRIVER=dummy "${BUILD_DIR}"/faudio_tests || die
+}
diff --git a/app-emulation/faudio/faudio-9999.ebuild b/app-emulation/faudio/faudio-9999.ebuild
deleted file mode 100644
index 51ecd606fc26..000000000000
--- a/app-emulation/faudio/faudio-9999.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# shellcheck disable=SC2034
-EAPI=7
-
-CMAKE_ECLASS=cmake
-CMAKE_MAKEFILE_GENERATOR="emake"
-MULTILIB_COMPAT=( abi_x86_{32,64} )
-
-inherit cmake-multilib virtualx multilib-build
-
-FAUDIO_PN="FAudio"
-FAUDIO_PV="${PV}"
-FAUDIO_P="${FAUDIO_PN}-${FAUDIO_PV}"
-
-if [[ "${PV}" == "9999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/FNA-XNA/${FAUDIO_PN}.git"
-else
- SRC_URI="https://github.com/FNA-XNA/${FAUDIO_PN}/archive/${FAUDIO_PV}.tar.gz -> ${FAUDIO_P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/${FAUDIO_P}"
-fi
-
-DESCRIPTION="FAudio - Accuracy-focused XAudio reimplementation for open platforms"
-HOMEPAGE="https://fna-xna.github.io/"
-LICENSE="ZLIB"
-SLOT="0"
-
-IUSE="+abi_x86_32 +abi_x86_64 debug dumpvoices gstreamer xnasong test utils"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )"
-
-DEPEND="
- >=media-libs/libsdl2-2.0.9[sound,${MULTILIB_USEDEP}]
- gstreamer? (
- media-libs/gstreamer:1.0[${MULTILIB_USEDEP}]
- media-libs/gst-plugins-base:1.0[${MULTILIB_USEDEP}]
- )
-"
-RDEPEND="${DEPEND}"
-
-multilib_src_configure() {
- local mycmakeargs=(
- "-DCMAKE_INSTALL_BINDIR=bin"
- "-DCMAKE_INSTALL_INCLUDEDIR=include/${FAUDIO_PN}"
- "-DCMAKE_INSTALL_LIBDIR=$(get_libdir)"
- "-DCMAKE_BUILD_TYPE=$(usex debug Debug Release)"
- "-DFORCE_ENABLE_DEBUGCONFIGURATION=$(usex debug ON OFF)"
- "-DBUILD_TESTS=$(usex test ON OFF)"
- "-DBUILD_UTILS=$(usex utils ON OFF)"
- "-DDUMP_VOICES=$(usex dumpvoices ON OFF)"
- "-DGSTREAMER=$(usex gstreamer ON OFF)"
- "-DXNASONG=$(usex xnasong ON OFF)"
- )
- cmake_src_configure
-}
-
-src_configure() {
- cmake-multilib_src_configure
-}
-
-multilib_src_compile() {
- cmake_build
- emake -C "${BUILD_DIR}" all
-}
-
-multilib_src_install() {
- # FIXME: do we want to install the FAudio tools?
- cmake_src_install
-
- sed -e "s@%LIB%@$(get_libdir)@g" -e "s@%PREFIX%@${EPREFIX}/usr@g" \
- "${FILESDIR}/faudio.pc" > "${T}/faudio.pc" \
- || die "sed failed"
- insinto "/usr/$(get_libdir)/pkgconfig"
- doins "${T}/faudio.pc"
-
- if use test; then
- mkdir -p "${T}/$(get_libdir)" || die
- cp "${BUILD_DIR}/faudio_tests" "${T}/$(get_libdir)/" || die "cp failed"
- fi
-}
-
-faudio_test() {
- XDG_RUNTIME_DIR="/run/user/0" virtx "${T}/$(get_libdir)/faudio_tests"
-}
-
-pkg_postinst() {
- use test || return
-
- # FIXME: FAudio tests are broken and also don't appear to work
- # in the Portage sandbox.
- multilib_foreach_abi faudio_test
-}
diff --git a/app-emulation/faudio/files/faudio.pc b/app-emulation/faudio/files/faudio.pc
deleted file mode 100644
index cdb3bf49e64a..000000000000
--- a/app-emulation/faudio/files/faudio.pc
+++ /dev/null
@@ -1,11 +0,0 @@
-prefix=%PREFIX%
-exec_prefix=${prefix}
-libdir=${prefix}/%LIB%
-includedir=${prefix}/include/FAudio
-
-Name: faudio
-Description: Accuracy-focused XAudio reimplementation for open platforms
-Version:
-
-Libs: -L${libdir} -lFAudio
-Cflags: -I${includedir}
diff --git a/app-emulation/faudio/metadata.xml b/app-emulation/faudio/metadata.xml
index 697202e2f1d7..430772900c80 100644
--- a/app-emulation/faudio/metadata.xml
+++ b/app-emulation/faudio/metadata.xml
@@ -1,26 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>wine@gentoo.org</email>
- <name>Wine</name>
- <description>
- This package must be kept in sync with repo/proj/wine repository.
- Any changes need to be run past the maintainer to ensure the two repositories are kept in sync.
- </description>
- </maintainer>
+ <!-- maintainer-needed -->
<longdescription>
-FAudio, is an XAudio reimplementation that focuses solely on developing fully accurate DirectX Audio runtime libraries
+FAudio is an XAudio reimplementation that focuses solely on developing fully accurate DirectX Audio runtime libraries
for the FNA project, including XAudio2, X3DAudio, XAPO, and XACT3.
-Project Website: http://fna-xna.github.io/
+Project Website: https://fna-xna.github.io/
</longdescription>
<use>
<flag name="dumpvoices">FAudio dumps buffer data to individual files with RIFF/XWMA headers, usable with players like ffplay/testxwma.</flag>
- <flag name="test">Build and run faudio testsuite.</flag>
- <flag name="utils">Build all faudio utilities.</flag>
- <flag name="xnasong">Build support for optional XNG_SONG component (note: this not required by
- <pkg>app-emulation/wine-staging</pkg>, <pkg>app-emulation/wine-vanilla</pkg> for faudio XAudio support).</flag>
</use>
<upstream>
<remote-id type="github">FNA-XNA/FAudio</remote-id>