summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/fuse')
-rw-r--r--app-emulation/fuse/Manifest1
-rw-r--r--app-emulation/fuse/files/multiple-definition.patch13
-rw-r--r--app-emulation/fuse/fuse-1.5.7.ebuild81
-rw-r--r--app-emulation/fuse/fuse-1.6.0-r1.ebuild (renamed from app-emulation/fuse/fuse-1.6.0.ebuild)23
-rw-r--r--app-emulation/fuse/metadata.xml2
5 files changed, 15 insertions, 105 deletions
diff --git a/app-emulation/fuse/Manifest b/app-emulation/fuse/Manifest
index 62b174565f78..127daceb5a37 100644
--- a/app-emulation/fuse/Manifest
+++ b/app-emulation/fuse/Manifest
@@ -1,2 +1 @@
-DIST fuse-1.5.7.tar.gz 1634568 BLAKE2B 9d2f3c310132dc57336995c31adeb37d727506719d1089b2009a2f44cbfa59fc9c4e9252aeff64cdd22b7326328518b5da33af51be687f321b891b9d1dd2b646 SHA512 ac11e03fc203f98433253fb72d7700cf6285ad8662147f318bb4ceda3888bc865b80d85473a3b2bda9e0971989b1579fc928f41ddabbf01d58358362066be13d
DIST fuse-1.6.0.tar.gz 1686171 BLAKE2B d1e6b166f2f649f408349b16a5eb40dd414750ed7a805eb6505b6c81be6ed7bcaa4e6f0b14057645172add1b1a77881f90b64767390fe1a64a486168f452d29d SHA512 5096b24b5b3d812942a7ad401b886b6a99f5493686912cb4aff18ede65404ae97a9bcafa6337aaed4378382f2a170918797d7d4570bb809476be5aa9fc625b8b
diff --git a/app-emulation/fuse/files/multiple-definition.patch b/app-emulation/fuse/files/multiple-definition.patch
deleted file mode 100644
index 8a8e9d7d1758..000000000000
--- a/app-emulation/fuse/files/multiple-definition.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -Naur fuse-1.5.7/ui/widget/widget.c fuse-1.5.7-patched/ui/widget/widget.c
---- fuse-1.5.7/ui/widget/widget.c 2018-08-06 15:36:04.000000000 +0200
-+++ fuse-1.5.7-patched/ui/widget/widget.c 2020-09-20 15:27:42.045382588 +0200
-@@ -90,9 +90,6 @@
-
- static widget_recurse_t widget_return[10]; /* The stack to recurse on */
-
--/* The settings used whilst playing with an options dialog box */
--settings_info widget_options_settings;
--
- static int widget_read_font( const char *filename )
- {
- utils_file file;
diff --git a/app-emulation/fuse/fuse-1.5.7.ebuild b/app-emulation/fuse/fuse-1.5.7.ebuild
deleted file mode 100644
index 063ecf27471a..000000000000
--- a/app-emulation/fuse/fuse-1.5.7.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="Free Unix Spectrum Emulator by Philip Kendall"
-HOMEPAGE="http://fuse-emulator.sourceforge.net"
-SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="alsa ao backend-fbcon backend-sdl backend-svga backend-X gpm joystick memlimit png xml"
-
-# Only one UI back-end can be enabled at a time
-REQUIRED_USE="?? ( backend-fbcon backend-sdl backend-svga backend-X )"
-
-RDEPEND="
- >=app-emulation/libspectrum-1.4.4
- dev-libs/glib:2
- alsa? ( media-libs/alsa-lib )
- ao? ( media-libs/libao )
- backend-sdl? ( media-libs/libsdl )
- backend-svga? ( media-libs/svgalib )
- backend-X? ( x11-libs/libX11 x11-libs/libXext )
- !backend-fbcon? ( !backend-sdl? ( !backend-svga? ( !backend-X? ( x11-libs/gtk+:3 ) ) ) )
- gpm? ( sys-libs/gpm )
- joystick? ( !backend-sdl? ( media-libs/libjsw ) )
- png? ( media-libs/libpng:0= sys-libs/zlib )
- xml? ( dev-libs/libxml2:2 )"
-DEPEND="${RDEPEND}
- backend-fbcon? ( virtual/linux-sources )
- dev-lang/perl
- virtual/pkgconfig"
-
-DOCS=( AUTHORS ChangeLog README THANKS )
-
-PATCHES=(
- "${FILESDIR}"/multiple-definition.patch
- "${FILESDIR}"/remove-local-prefix.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- --without-win32
- $(use_with alsa)
- $(use_with ao libao)
- $(use_with gpm)
- $(use_with joystick)
- $(use_enable memlimit smallmem)
- $(use_with png)
- $(use_with xml libxml2)
- )
-
- if use backend-sdl; then
- myconf+=("--with-sdl")
- elif use backend-X; then
- myconf+=("--without-gtk")
- elif use backend-svga; then
- myconf+=("--with-svgalib")
- elif use backend-fbcon; then
- myconf+=("--with-fb")
- else
- myconf+=("--with-gtk")
- fi
-
- use joystick && myconf+=( $(use_enable backend-sdl ui-joystick) )
-
- econf "${myconf[@]}"
-}
-
-src_test() {
- emake test
-}
diff --git a/app-emulation/fuse/fuse-1.6.0.ebuild b/app-emulation/fuse/fuse-1.6.0-r1.ebuild
index ddec66d72acc..0099b7ffcc40 100644
--- a/app-emulation/fuse/fuse-1.6.0.ebuild
+++ b/app-emulation/fuse/fuse-1.6.0-r1.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools xdg
+inherit autotools flag-o-matic xdg
DESCRIPTION="Free Unix Spectrum Emulator by Philip Kendall"
HOMEPAGE="http://fuse-emulator.sourceforge.net"
-SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/fuse-emulator/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="alsa ao backend-X backend-fbcon +backend-gtk3 backend-sdl backend-svga gpm joystick memlimit png -pulseaudio +xml +zlib"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+IUSE="alsa ao backend-X backend-fbcon +backend-gtk3 backend-sdl backend-svga gpm joystick memlimit png pulseaudio +xml +zlib"
# TODO:
# - allow using sdl audio driver without using for the UI
@@ -21,7 +21,8 @@ IUSE="alsa ao backend-X backend-fbcon +backend-gtk3 backend-sdl backend-svga gpm
# At most one audio driver and at most one UI back-end can be enabled at a time
REQUIRED_USE="?? ( alsa ao backend-sdl pulseaudio )
- ?? ( backend-X backend-fbcon backend-gtk3 backend-sdl backend-svga )"
+ ?? ( backend-X backend-fbcon backend-gtk3 backend-sdl backend-svga )
+ png? ( zlib )"
RDEPEND="
>=app-emulation/libspectrum-1.5.0[zlib?]
@@ -35,7 +36,7 @@ RDEPEND="
gpm? ( backend-fbcon? ( sys-libs/gpm ) )
joystick? ( !backend-sdl? ( media-libs/libjsw ) )
png? ( media-libs/libpng:0= )
- pulseaudio? ( media-sound/pulseaudio )
+ pulseaudio? ( media-libs/libpulse )
xml? ( dev-libs/libxml2:2 )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
@@ -64,8 +65,12 @@ _fuse_audio_driver() {
}
src_prepare() {
- xdg_src_prepare
+ default
+ xdg_environment_reset
eautoreconf
+
+ # Bug #854522
+ filter-lto
}
src_configure() {
diff --git a/app-emulation/fuse/metadata.xml b/app-emulation/fuse/metadata.xml
index f6bb92e4f4f6..5b50c50c218a 100644
--- a/app-emulation/fuse/metadata.xml
+++ b/app-emulation/fuse/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>marecki@gentoo.org</email>