summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/glean/glean-1.23.0-r1.ebuild')
-rw-r--r--app-emulation/glean/glean-1.23.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emulation/glean/glean-1.23.0-r1.ebuild b/app-emulation/glean/glean-1.23.0-r1.ebuild
new file mode 100644
index 000000000000..d5c813a3e0ad
--- /dev/null
+++ b/app-emulation/glean/glean-1.23.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9,10,11,12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple program to write static config from config-drive"
+HOMEPAGE="https://opendev.org/opendev/glean"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/pbr[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}