summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/guestfs-tools')
-rw-r--r--app-emulation/guestfs-tools/Manifest2
-rw-r--r--app-emulation/guestfs-tools/guestfs-tools-1.48.2.ebuild (renamed from app-emulation/guestfs-tools/guestfs-tools-1.48.0.ebuild)26
2 files changed, 20 insertions, 8 deletions
diff --git a/app-emulation/guestfs-tools/Manifest b/app-emulation/guestfs-tools/Manifest
index 5626fdc34c99..f8739c8d818b 100644
--- a/app-emulation/guestfs-tools/Manifest
+++ b/app-emulation/guestfs-tools/Manifest
@@ -1 +1 @@
-DIST guestfs-tools-1.48.0.tar.gz 12682919 BLAKE2B 27b4e5c47af222691b067c19e997112acaf0360cc9c089dedb0327959ff8d80ff929e2fea369f9895ed6e1fc80a339ca89db3b9eb32cf23328fc71972447a13e SHA512 8576ef0e283a02a112f785e8f1656b41c93be29e12617ee8c83033b90758736ea3c2d4ecfb446a86c7913e2c0b39a7c5666e8ad22682419cc877543a3825c489
+DIST guestfs-tools-1.48.2.tar.gz 12691067 BLAKE2B 305f281c19975f160c435b995d71ef2e18d09fc95f31e92efe8f79d811fc0a7efab27d14f766d5f6ee477fd43977167a3aabe5cc40498f125f925507fd2574d5 SHA512 e11cd5a38a1681e8b2fd56419d38ca0aaab659cb59d409b3572cadcd04fd4da3078fa33e7f21c99d11854ad08797ae24a8d71c041b1b7769fc36c1391b6eb162
diff --git a/app-emulation/guestfs-tools/guestfs-tools-1.48.0.ebuild b/app-emulation/guestfs-tools/guestfs-tools-1.48.2.ebuild
index 84ae94b176aa..718c2b33d14b 100644
--- a/app-emulation/guestfs-tools/guestfs-tools-1.48.0.ebuild
+++ b/app-emulation/guestfs-tools/guestfs-tools-1.48.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,14 +17,16 @@ SRC_URI="https://download.libguestfs.org/${PN}/${MY_PV_1}-${SD}/${P}.tar.gz"
LICENSE="GPL-2 LGPL-2"
SLOT="0/${MY_PV_1}"
-KEYWORDS="~amd64"
+if [[ ${SD} == "stable" ]] ; then
+ KEYWORDS="amd64"
+fi
IUSE="doc +ocaml +perl test"
RESTRICT="!test? ( test )"
# Failures - doc
COMMON_DEPEND="
!<app-emulation/libguestfs-1.46.0-r1
- app-arch/cpio
+ app-alternatives/cpio
app-arch/lzma
app-arch/unzip[natspec]
app-arch/xz-utils
@@ -55,7 +57,8 @@ COMMON_DEPEND="
"
# Some OCaml is always required
# bug #729674
-DEPEND="${COMMON_DEPEND}
+DEPEND="
+ ${COMMON_DEPEND}
>=dev-lang/ocaml-4.03:=[ocamlopt]
dev-ml/findlib[ocamlopt]
doc? ( app-text/po4a )
@@ -67,8 +70,13 @@ DEPEND="${COMMON_DEPEND}
)
)
"
-BDEPEND="virtual/pkgconfig"
-RDEPEND="${COMMON_DEPEND}
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${COMMON_DEPEND}
app-emulation/libguestfs-appliance
"
@@ -87,6 +95,9 @@ src_configure() {
# bug #794877
tc-export AR
+ # Needs both bison+flex (bug #915339, see configure too)
+ unset YACC LEX
+
if use test ; then
# Skip Bash test
# (See 13-test-suite.log in linked bug)
@@ -124,7 +135,8 @@ src_configure() {
append-ldflags "-Wl,-R${ESYSROOT}/usr/$(get_libdir)/xcrypt"
fi
- econf \
+ # Test suite at least has a bunch of bashisms
+ SHELL="${BROOT}"/bin/bash CONFIG_SHELL="${BROOT}"/bin/bash econf \
$(usex doc '' PO4A=no) \
$(use_enable ocaml) \
$(use_enable perl)