summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/gxemul')
-rw-r--r--app-emulation/gxemul/Manifest1
-rw-r--r--app-emulation/gxemul/files/gxemul-0.6.0-fix-mkstemp-test.patch10
-rw-r--r--app-emulation/gxemul/files/gxemul-0.6.0-fix-mymkstemp.patch11
-rw-r--r--app-emulation/gxemul/gxemul-0.6.0-r1.ebuild50
-rw-r--r--app-emulation/gxemul/gxemul-0.6.2.ebuild4
-rw-r--r--app-emulation/gxemul/metadata.xml2
6 files changed, 3 insertions, 75 deletions
diff --git a/app-emulation/gxemul/Manifest b/app-emulation/gxemul/Manifest
index 0e40fbe91e05..4d1ab5f52d49 100644
--- a/app-emulation/gxemul/Manifest
+++ b/app-emulation/gxemul/Manifest
@@ -1,2 +1 @@
-DIST gxemul-0.6.0.tar.gz 3598795 BLAKE2B 01bab252b8497379cc819899d9030fd267cf7679a90a421f435c6cb9ce84fedbdbd0ff23a11e0c91a17e41e166488562b4e173b3793cdbc2dd53b70701351429 SHA512 38108c7e4f1332bf80046a63e4a7c5e0fbce7f83a62fdeaa4518ef02947d7de83aac20b0307d286b7eb5d9c721b8400d449d4f244b2bc9358a2502fa21f56b73
DIST gxemul-0.6.2.tar.gz 5897883 BLAKE2B 9f5b76d955dc3e1a5b1623aaf491f18376456f33cfaa6a4c1633480980c35bb99172075135cfc1ca942ae3b0f34c4eb11c4aec4bc00272da8bb905176ddcea4a SHA512 4f389c509f9ecf39603ceed50e899e2bee285d3fefac9b3214076115ee71b5a7a68d1d92690b6debc8de5cf5f0303da83b3cc921a5c0b5eb4c7ad89baa730b59
diff --git a/app-emulation/gxemul/files/gxemul-0.6.0-fix-mkstemp-test.patch b/app-emulation/gxemul/files/gxemul-0.6.0-fix-mkstemp-test.patch
deleted file mode 100644
index cf8b18379cd4..000000000000
--- a/app-emulation/gxemul/files/gxemul-0.6.0-fix-mkstemp-test.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/configure 2012-11-03 09:08:09.373041529 +0000
-+++ b/configure 2012-11-03 09:08:31.999585979 +0000
-@@ -705,6 +705,7 @@
- # mkstemp missing?
- printf "checking for mkstemp... "
- printf "#include <unistd.h>
-+#include <stdlib.h>
- int main(int argc, char *argv[]) { int x; char *y = \"abc\";
- x = mkstemp(y); return 0;}\n" > _tests.cc
- $CXX $CXXFLAGS _tests.cc -o _tests 2> /dev/null
diff --git a/app-emulation/gxemul/files/gxemul-0.6.0-fix-mymkstemp.patch b/app-emulation/gxemul/files/gxemul-0.6.0-fix-mymkstemp.patch
deleted file mode 100644
index c9e21bcc4b33..000000000000
--- a/app-emulation/gxemul/files/gxemul-0.6.0-fix-mymkstemp.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/old_main/misc.cc 2012-11-03 08:47:34.309732354 +0000
-+++ b/src/old_main/misc.cc 2012-11-03 08:47:02.096573614 +0000
-@@ -122,7 +122,7 @@
- p++;
- }
-
-- h = open(templ, O_RDWR, 0600);
-+ h = open(templ, O_CREAT | O_RDWR, 0600);
- return h;
- }
-
diff --git a/app-emulation/gxemul/gxemul-0.6.0-r1.ebuild b/app-emulation/gxemul/gxemul-0.6.0-r1.ebuild
deleted file mode 100644
index 2dd8d8087fa6..000000000000
--- a/app-emulation/gxemul/gxemul-0.6.0-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="A Machine Emulator, Mainly emulates MIPS, but supports other CPU types"
-HOMEPAGE="http://gxemul.sourceforge.net/"
-SRC_URI="mirror://sourceforge/project/gxemul/GXemul/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
-IUSE="debug X"
-
-RDEPEND="X? ( x11-libs/libX11 )"
-DEPEND="${RDEPEND}
- X? ( x11-base/xorg-proto )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.6.0-gcc46.patch
- "${FILESDIR}"/${P}-fix-mymkstemp.patch # Bug 441558
- "${FILESDIR}"/${P}-fix-mkstemp-test.patch # Bug 441558
- "${FILESDIR}"/${PN}-0.6.0-no-doxygen.patch
-)
-
-src_prepare() {
- default
-
- sed -i configure -e 's|-O3||g' || die "sed configure"
- tc-export CC CXX
-}
-
-src_configure() {
- # no autotools
- ./configure \
- --disable-valgrind \
- $(use debug && echo --debug) \
- $(use X || echo --disable-x) \
- || die "configure failed"
-}
-
-src_install() {
- dobin gxemul
- doman man/gxemul.1
- dodoc HISTORY README
- docinto html
- dodoc -r doc/.
-}
diff --git a/app-emulation/gxemul/gxemul-0.6.2.ebuild b/app-emulation/gxemul/gxemul-0.6.2.ebuild
index 4f73577a5ce6..fbe24c090e49 100644
--- a/app-emulation/gxemul/gxemul-0.6.2.ebuild
+++ b/app-emulation/gxemul/gxemul-0.6.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,7 +7,7 @@ inherit toolchain-funcs
DESCRIPTION="A Machine Emulator, Mainly emulates MIPS, but supports other CPU types"
HOMEPAGE="http://gxemul.sourceforge.net/"
-SRC_URI="mirror://sourceforge/project/gxemul/GXemul/${PV}/${P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/project/gxemul/GXemul/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
diff --git a/app-emulation/gxemul/metadata.xml b/app-emulation/gxemul/metadata.xml
index ce46ccfd0e80..bd88d1ef0ae4 100644
--- a/app-emulation/gxemul/metadata.xml
+++ b/app-emulation/gxemul/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
<longdescription>Machine Emulator. Supports emulation across several architectures. Primarily for MIPS support, but other platform support coming soon.</longdescription>